Classic SEO 2.0.1 Can't Import

Every time I try to import my Rank Math settings, I get the error:

The link you followed has expired. Please try again.

1 Like

Hello @NyssaTheHobbit thanks for reporting this.

Unfortunately, I’ve not been able to replicate this but it’s possible this is caused by certain server PHP settings.

Firstly, can you tell me which version of RM you’re trying to import from?

Secondly, I would recommend the following minimum PHP settings in your php.ini file:

upload_max_filesize = 32M
post_max_size = 32M
max_execution_time = 120

Alternatively, you can add the following lines to your wp-config.php file:

@ini_set( 'upload_max_size' , '32M' );
@ini_set( 'post_max_size', '32M');
@ini_set( 'max_execution_time', '120' );

You can do one or the other but not both.

If you don’t have access to the file system or PHP settings, you’ll need to ask your host to change them for you.

Then try again :slight_smile:

Let me know how you get on.


I think it was because RankMath was still running at the time. I shut it off and this time it worked.

I went into the posts and pages to see how they look when editing…Everything looks different. Instead of ratings and boxes, I get a custom fields drop-down. Is it supposed to look like that?

The short answer is no, it shouldn’t look any different - apart from one or two tweaks here and there.

Can you post a screenshot please so I know for sure what to look for?

I re-activated Classic SEO and this time the ratings and SEO boxes are showing, but they don’t show the imported settings. The settings are correct in the Custom Fields box, though. You can see below that the preview is different, for example, and the focus keywords didn’t transfer.


The Custom Fields box is a ClassicPress (and WordPress) feature and isn’t actually part of Classic SEO. You can show or hide it by clicking on the Screen Options tab at the top of the page and clicking the Custom Fields box.


If you want to view the CPSEO custom fields, then just add the following lines to your theme’s functions.php:

function my_hide_cpseo_meta( $protected, $meta_key ) {
	return ( substr( $meta_key, 0, strlen( 'cpseo_' ) ) === 'cpseo_' ) ? false : $protected;
add_filter( 'is_protected_meta', 'my_hide_cpseo_meta', 10, 2 );

However, ordinarily, you shouldn’t need to touch these.

The only other thing I would add is that if Classic SEO is enabled, you can ignore all rank_math_ fields in custom fields as they don’t apply to CPSEO.

Okay, I tried it again and it seems to be running all right now–except for the titles. Not all, but some of my pages show up with %title% %sep% %sitename% instead of the title. Also, Global Meta is not saving my changes on that site. I’m currently setting it up on my other site to see how that goes.

One site lets me make changes in the settings; the other one doesn’t.

I also noted that one site didn’t bring over the keywords in the latest posts.

Hi @NyssaTheHobbit,

I’ve just got a few questions to try and help track this down:

  1. What version of RM are you importing from?
  2. Which pages show %title% %sep% %sitename% instead of the title? Is there any commonality? For instance, are they all of post type ‘X’ or is it random?
  3. Are there any significant differences between your two sites - such as different hosting, different PHP versions, different plugins, etc?
  4. Do any errors show up at any time? Can you also take a look at your PHP error log to see if there’s any relevant info in there please.

Any additional info you can provide will be useful.