Classic SEO - issue editing snippet/title

Just updated last night, and I cannot seem to edit snippet or custom title. Also I cannot put any links within the posts.

Not sure if this is related to the update or not.

Otherwise I might try and roll back to the previous version (if you tell me how) and I can see if the problem still exists, in case it is an error with another plugin.

It was working perfectly until the update, so that is why I am assuming that this is what the problem is.

3 Likes

Thanks for reporting @spanner44. These features are working fine for me on all my installations (5), not that that’s any consolation to you of course.

I’d be interested to learn if anyone else is having these problems?

Couple of things to start with:

  1. Can you tell me what other plugins you’ve got enabled and also what theme you’re using?
  2. Are you getting any errors in your PHP error log?

Thanks again for reporting back.

3 Likes

Where do I find the php error log ?

Plugins activated:

AddToAny Share Buttons
Anti-spam
Brave Payments Verification
Classic SEO
Cloudflare
Contact Form 7
Flying Pages
GitHub Updater
Google Analytics Dashboard for WP (GADWP)
NextScripts: Social Networks Auto-Poster
Pin It Button On Image Hover And Post
Really Simple SSL
Smush
Subscribe2
Top 10
UpdraftPlus - Backup/Restore
WP Edit
WP Fastest Cache
WP Mail SMTP
WP-Optimize - Clean, Compress, Cache
wpDiscuz

Installed and up to date, but not activated are Rankmath and WYSIWYG Advanced

Theme that I am using is News Portal ( Version: 1.1.16) by Mystery Themes

Everything worked ok yesterday morning and afternoon. I then updated last night, Classic SEO and then I noticed Github also needed updating and did that as well.

I went to do a post this morning, when I then noticed the problems.

If you explain how I can roll back, then I can try that to see if the problem persists.

Many Thanks

2 Likes

The PHP error log is usually a file in the root of your installation called error_log

1 Like

@spanner44 thanks for the info. You may also find a file called debug.log in wp-content depending on your setup.

But I agree it looks like rolling back a version or two will help. I’ll get this sorted and get back to you.

Just checked the error log and the last recorded error is from 24th October, so before this upgrade.

2 Likes

Bizarre. I’ll sort out earlier versions for you to download shortly.

Many thanks

1 Like

Here’s download links for v0.3.0 and v0.3.1. Let me know if you need one for v0.2.2.

https://github.com/ClassicPress-research/classicpress-seo/archive/v0.3.0.zip

https://github.com/ClassicPress-research/classicpress-seo/archive/v0.3.1.zip

The best way of rolling back to either of these versions is to use the file system (which hopefully you’ll have access to via cPanel, FTP or something else).

  1. Extract the zip archive to your local drive.
  2. Delete everything in the current classicpress-seo folder on your server (but not the folder itself).
  3. Upload all files and folders from the zip (e.g. classicpress-seo.php, assets, etc.) into the existing classicpress-seo on your server.

You should be good to go after this. The plugin should still be activated.

If you need any more help, give me a shout.

Thanks.

1 Like

I have tried both of those zips but the problem is the same.

If i revert back to rankmath, then everything is normal, but when I switch back to classicSEO, the problem returns.

Would it be better to remove classicseo altogether and the try to reinstall it once again ?

I just tried the master branch and it seemed to be ok on a clean site. I’m wondering if you experienced a JS issue or something.

1 Like

I really am not sure. As i say, I have now for the moment reverted back to Rankmath and everything seems to be back to normal, so not sure what is going on.

I noticed when I installed the latest two zips that were provided, that the name stayed the same (classicseo), which I think only changed for me when I did the latest update last night. (Not sure if that is relevant or not)

If I delete it and then reinstall it, do you think that this will make a difference.

I am a bit busy for a few days, so will leave it for now, and try again shortly.

1 Like

It’s possible it may be a caching problem somewhere along the line. This could be in your browser, Cloudflare or WP Fastest Cache.

When you next get chance @spanner44, before uninstalling / deleting anything, could you just make sure that all caches are cleared and then give it another try please.

The change of name to Classic SEO was introduced in v0.3.0.

1 Like

I did clear the cache each time, but still the same results.

Not sure if this is linked to the same problem, but about 8 days ago, a contributor to my site asked me if I had changed my external links to no-follow, which I hadn’t.

I was trying to get to the bottom of this, but since switching back to rankmath, this seems to have resolved itself and all the links went back to what they were before.

I suppose the best way of checking this is to disable all the plugins, or at last those updated in the last few weeks and reactivate them one by one.

Mind you if you have a link to an earlier version, I would also like to try that as well, as I am sure I only noticed the name change on this update (which I did seem odd as I know that the change of the name was discussed here in the forums), so it might not of updated to v3.0 although I do always check and update when notified, so can only presume that the Github updated plugin didn’t inform me until this latest update.

2 Likes

OK thanks @spanner44. It’s definitely something weird that’s for sure.

Since switching back to RM, have you tried switching back to Classic SEO again? I think that’s worth a try.

In the meantime, I’ll prepare a v0.2.2 download.

The GitHub Updater can be a bit slow at notifying you of updates. Sometimes you either need to clear the cache in the updater or do a hard browser reset (ctrl-F5 or ctrl-shift-r…or the Mac equivalent) or both.

1 Like

Version 0.2.2 can be downloaded here:

https://github.com/ClassicPress-research/classicpress-seo/archive/v0.2.2.zip

1 Like

Don’t want to go off-topic here… I think it’s probably core (rather than GitHub Updater) that takes a while to find the update. There’s a transient set in the options table called _site_transient_update_plugins; this transient ensures the system is only checking for updates ever 12 hours (for performance reasons.) If you delete the transient, the update check will be forced through (and the transient reset upon completion.)

2 Likes

Yes, that’s a valid point. I’m sure the Refresh Cache button in the Updater just deletes the transient but I haven’t looked too closely.

2 Likes

So after trying versions v0.3.0 and v0.3.1, clearing the caches in between, with no improvement, then reverting back to Rankmath, which got things back to normal, I have now tried 0.2.2 and can happily say that everything is back to normal.

So I have now reactivated Github Updater. Once the cache is refreshed, it indicates that a new version of Classic seo is available (0.3.2). An error occurs during the update and the site is stuck in Maintenance mode.

After deleting the maintenance folder and trying to update once again, I get this message:

The plugin classicpress-seo/classicpress-seo.php has been deactivated due to an error: Plugin file does not exist.

When I check the files on the server I still have a classicpress seo folder in the plugins folder, with the assets and languages folder as well as .gitignore and License.

So I start again and re-upload v0.2.2 back into the classicpress seo folder, clear cache, activate it and the settings still appear to be saved and everything appears normal again.

So I try with the update again. It fails and I get this message:

Update Failed: chb44.com | 524: A timeout occurred body{margin:0;padding:0} Error 524 Ray ID: 539e796e3f2bcda7 • 2019-11-22 22:54:12 UTC A timeout occurred You Browser Working Paris Cloudflare Working chb44.com Host Error What happened? The origin web server timed out responding to this request. What can I do? If you’re a visitor of this website: Please try again in a few minutes. If you’re the owner of this website: The connection to the origin web server was made, but the origin web server timed out before responding. The likely cause is an overloaded background task, database or application, stressing the resources on your web server. To resolve, please work with your hosting provider or web development team to free up resources for your database or overloaded application. Additional troubleshooting information here. Cloudflare Ray ID: 539e796e3f2bcda7 • Your IP: 2a01:cb05:832f:9700:bc7c:d26f:c724:8fd6 • Performance & security by Cloudflare

And my site then gets stuck into maintenance mode.

Haven’t a clue if this is a problem with my site, my hosting, the github updater or something else.

Eventually after 4 attempts, it updates to version 0.3.1

After once again clearing the cache, I notice that the same problem that I was having previously of not being able to edit snippet and not insert links has returned.

Will revert back to v0.2.2 for now.

3 Likes

I’ve been carrying out some tests.

Updating

Update available but doesn’t update

I ran into an issue where on the plugins page, it says there was an update available for Classic SEO, from 0.3.1 to 0.3.2. After updating, the version remained at 0.3.1 and I still got the update available notice. Tried a few times, same result. I then noticed that the GitHub Updater was fetching v0.3.1 each time, hence the reason the update was seemingly failing. After clearing the Updater cache, the update worked first time.

So in this case, it would appear that it’s necessary to click on the “Refresh Cache” button in GitHub Updater settings before every update.

Update fails with “deactivated due to an error” message

You may get a message similar to the following after updating Classic SEO:

The plugin classicpress-seo/classicpress-seo.php has been deactivated due to an error: Plugin file does not exist.

I suspect this issue is to do with folder names and the way GitHub packages the files into the zip.

I’ve flagged this as an issue which I will look into.

Unable to edit snippets & add links

I’m struggling with this one. I can’t reproduce this at all.

I’ve tested using these themes:

  • ClassicPress TwentySeventeen
  • Twenty Nineteen
  • News Portal
  • GeneratePress
  • Storefront
  • Divi
  • Astra

and with the these active plugins:

  • Contact Form 7
  • Flying Pages
  • WP Edit
  • WP Fastest Cache
  • WP Mail SMTP
  • WP-Optimize
  • AddToAny Share Buttons
  • Anti-spam (By webvitaly)
  • NextScripts: Social Networks Auto-Poster
  • Pin It Button On Image Hover And Post

Everything works as expected for me.

Could you tell me exactly what does, or does not, happen when you try to edit the snippet / title and when you try to add a link to the page? For instance, is the “Edit Snippet” button disabled and when you click on it nothing happens?

Calling all Classic SEO users

I could do with some help in trying to track this problem down. I know @CodePotent has said he can’t reproduce the issue. I’d be grateful if others could try to a) edit the snippet on a page and post and b) add a link into a post and page.

Could you please report back here either way and let me know what theme you’re using.

Thanks!!

3 Likes