ClassicPress plugin Wordpress 5.8.1 not working here

This plugin supports WordPress versions 4.9.0 to 5.8 (and some newer development versions).
You are running WordPress version 5.8.1.
It looks like you are using the Twenty Twenty-One theme. Unfortunately it is incompatible with ClassicPress.
Consider switching to a different theme, perhaps an older core theme, and try again.
We are not aware that any of your active plugins are incompatible with ClassicPress.
ClassicPress supports PHP versions 5.6 and newer.
You are using PHP version 7.2.34.
ClassicPress only supports communicating with the ClassicPress.net API over SSL.
This site supports making outgoing connections securely using SSL.
Your WordPress core files will be overwritten.
You have not modified any core files.

Sorry, we can’t switch this site to ClassicPress at this time.

Try using a theme that is compatible?
Like twenty seventeen should for example be…

Right. Because of WordPress 5.8.1

Our api probably didn’t yet update to that version and expects 5.8 or lower

One sec, we have a doc how you can circumvent this issue…

Okay sure. That theme seems to work but still, the Wordpress 8.1 is not allowing it work or be updated through it .

1 Like

Try this

Adding the filter will knock out the WP version check

And please make sure you’ve a backup!!

Thanks the site more less fresh so nothing on it so far.

maybe in that case the best is to just install CP from fresh (if there is no content whatsoever, that is)

This can save a few steps of “migration”

In any case, let us know if any other issue pops up…

I was thinking that is the problem or issue down to Wordpress last update making your plugin in theory not work ?

Yes, as mentioned above, our API still expects WP 5.8 or lower, and with the filter linked in the DOC it can be resolved.

The plugin works, it just expects a version 5.8 or lower, and thus, you need to tell it with the filter to ignore the version (for now, we are in the progress of updating the API to also recognise 5.8.1, see https://github.com/ClassicPress/ClassicPress-APIs/pull/32)

But if your install is fresh, there is no need to migrate from WP
You could just install CP directly, effectively avoiding any need to migrate

Sounds like this going to turn into a nightmare thanks for the help but when the plugin does not work and getting filezilla is proving unpleasant as well to make this job happen I will just use it is sign then try out better software instead of next.js instead since can work that easier than your plugin .

The migration support for WordPress 5.8.1 is coming soon. Work has been done to implement it, we’re just testing it to make sure everything works and doesn’t cause issues. We take extra time testing to ensure everything works, even if that means we can’t support the new version immediately.

Give it a few days, and we should get this completed hopefully.

Migration from WP 5.8.1 is enabled now. Thanks @MattyRob for the pull request and thank you all for testing: https://github.com/ClassicPress/ClassicPress-APIs/pull/32

2 Likes

6 posts were split to a new topic: Automating version display in migration documentation

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.