Google Search Console not working after beta 4 update

Continued from Classic SEO Beta 4 Released.

Beta 4 is worse than beta 3.

Google search console features do not work.
Two days after the update, my situation is as follows:


The manual cache refresh button is gray and inactive

Regards,
Коко :slight_smile:

Thanks for reporting this.

There are no changes in beta 4 that should affect the operation of search console. I know this is of no help to you but it’s working fine for me on the 2 sites on which I have search console enabled.

Here’s some troubleshooting pointers / questions to get us started and to try and get the “Update cache manually” button reactivated on your site:

  1. Are you getting any error messages in the browser console?
  2. Are you using a cache plugin? If so, a) which one and b) please clear the cache completely.
  3. Go to Classic SEO -> General Settings -> Search Console and check that your site is still authorised to access Google Search Console.
  4. While on the same page, clear your browser cache (ctrl+F5 or ctrl+shift+r in Firefox).
  5. Go to Classic SEO -> General Settings -> Status & Tools -> Tools tab. Click on “Remove transients” button.
  6. Navigate to Classic SEO -> Search Console and clear your browser cache (as above).
  7. Is Cron running on your site?
    a) Make sure that DISABLE_WP_CRON is not set to true in wp-config.php (if it doesn’t exist in wp-config.php, that’s fine).
    b) Install and activate WP-Crontrol, then go to Tools -> Cron Events. In the Hook column, search for cpseo/search_console/get_analytics and delete it (you can then deactivate and remove WP-Crontrol).
    c) Go back to Classic SEO -> General Settings -> Search Console and clear your browser cache.

Hopefully one of the above steps will reactivate the “Update cache manually” button.

Let me know how you get on.

If anyone else is using the Search Console feature, could you let me know here whether or not you are experiencing similar issues.

Thanks.

2 Likes

I’ve just checked and in 7 sites using the Search Console feature everything is fine.

1 Like

Thank you for your help :slight_smile:

  1. There are no errors in the browser console.
  2. I use W3 total cache. The cache was completely deleted before I wrote here.
  3. The site was authorized in the Google search console. I checked this both on the plugin page and on my smartphone (the phone and the site use the same Google account). However, I revoked the permit and then re-authorized it. This activates the “Update cache manually” button. At the same time, it returned the standard text to the “Update cache manually” button. Previously, the button showed “Fetching in Progress”, which makes me think that something went wrong while retrieving data from Google. At the moment the button is active, but the cache has not been retrieved yet.
  4. Browser cache cleared.
  5. I used the “Remove transients” button before writing here. It had no effect.
  6. Cache cleared.
  7. I have a problem here. The thing is, years ago I moved Cron Jobs from WordPress to a Control panel. I’m not sure I want to put them back in WordPress, even if it means the function “search console” doesn’t work. Cron is also responsible for pre-generating page cache, and I prefer to do this at a specific time than when a visitor accesses the site.

I’m thinking of waiting to see if the data will be available after time. At what interval does Classic Seo retrieve cache from Google? Do I have control over this setting?

2 Likes

Thanks @Simone. That’s good to know.

Thanks @KokoFresha.

The cron job runs each day at midnight. At the moment, it’s not possible to change this.

Just one thing regarding W3TC. I’ve come across cases where deleting the cache from admin doesn’t actually do much so have had to resort to manually deleting the cache folder using FTP. Might be worth trying if you haven’t already.

Apart from that, the only other thing I can think of for now is to try deactivating and reactivating Classic SEO…if you haven’t already :slight_smile:

1 Like