Installatron - Unable to determine whether a ClassicPress update is available

I am volunteering to create a website for a non-profit, their tech guys have chosen for the host - GoDaddy. The tech guys used Installatron to create the ClassicPress install that I am supposed to use.

Installatron does not have Version 1.3 as a choice on install just 1.2(recommended) and lower.

My dev site that I am attempting to migrate is Version 1.3, (not because I wanted it to be, but because ClassicPress updates automagically.)

Expected behavior

ClassicPress dashboard should be nagging me to update to 1.3

Current behavior

Not only is it not nagging but the update checker says:

" Unable to determine whether a ClassicPress update is available.

You may be running a customized build of ClassicPress, or your server may be having internet connectivity problems."

So I have no option to update to 1.3

Context - My questions or comments

  1. I am letting the community know what is going on at Installatron or possibly GoDaddy?
  2. Does Installatron create a customized build, I don’t think I want that?
  3. To manually update to Version 1.3 - overwrite all of wp-includes? this is so WP1.0, I have forgotten :angry:

Volunteering ain’t too great sometimes

We need to check with Installatron to see if they need to update CP manually on their end. They might not know about our URL.

As for updating CP. Once CP 1.2 is installed, regular updates should kick in and you should be able to upgrade to the latest version 1.3 from the dashboard. Are you not able to do so?

Thanks for reporting this.

Thank you for the quick response viktor, yes I am unable to upgrade:

1 Like

Installatron may not know about the latest version of ClassicPress, but it shouldn’t have to: you should be prompted to update automatically.

The most likely cause for your site not seeing the upgrade is the recent expiration of a SSL certificate used by a large portion of the Internet. More info about what happened here: Let’s Encrypt’s root certificate has expired, and it might break your devices – TechCrunch

Try installing this plugin which is intended to diagnose and fix this issue:

We’ll be shipping our part of this fix in ClassicPress v1.3.1, but the other part has to be done by your web host: GoDaddy needs to upgrade the version of cURL that is used by your PHP installation, and/or remove the expired “DST Root CA X3” certificate from your web server.

In the meantime that plugin should help, please give it a try and let us know what it says (send a screenshot). More info about the plugin here: Sorry, we can't switch this site to ClassicPress at this time - #13 by james

1 Like

I sent them an email and asked them to update to 1.3.0, hopefully they’ll do it.

1 Like


As you can see by the screenshot, I tried disabling certificate verification and checked on the “updates” page, it did not change the behavior of the “Check for Updates” button or the nag.

1 Like

Based on that output, the plugin should work for you. Click the button to disable certificate verification, then immediately go to Dashboard > Updates and click Check Again. Be sure to do that and apply the update before the 3 minutes elapse.

This is a temporary solution - you will also need to get your web host to fix your server configuration.

I did it twice, it doesn’t seem to work in this case.

I remembered that AUTOMATIC_UPDATER_DISABLED was set to ‘true’ in config. I changed it to ‘false’ and tried the process again it still doesn’t work, but maybe this tells us that they do have a custom build?:


  • Turn off automatic updates since these are managed externally by Installatron.
  • If you remove this define() to re-enable ClassicPress’s automatic background updating
  • then it’s advised to disable auto-updating in Installatron.
    define(‘AUTOMATIC_UPDATER_DISABLED’, false);


1 Like

I’m not sure why it wouldn’t be working then.

There is another easy way to install updates, this time using the migration plugin which you can download from

Once that is open, you can go to “Tools > Switch to ClassicPress”, use the “Show advanced controls” section, and paste the URL to the latest version of ClassicPress ( in the text field.

You may need to chain this together with the previous plugin that will enable insecure requests for a few minutes first.

I guess I should mark this solved? I got the upgrade done with James last trick!


After following James’ instructions to upgrade to v1.3, I went back to the SSL Fix tool and got a new response!


I am not sure why that would happen either, but I’m glad you got a good result in the end.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.