Migrated my sites, had a couple problems and a solution for others


#1

I just migrated some of my sites and everything is working fine. No problems from any of the plugins. When I get time I’ll list all the plugins and theme that’s in use and working. I changed my theme’s functions.php file so it now says Powered by ClassicPress. I’m not sure what I can do but I’m going to try to find something I can do help on the project.

This is just an FYI for anyone using the migration plugin. For people that’s been doing this a while it won’t mean much. But for someone new it might help (I hope a lot of people switch). I just finished migrating 7 of my web sites. 5 went off without a hitch, but 2 didn’t go so well. I got a migration failed warning and then if you clicked on anything you get a plain white page. But don’t panic. You can try what I did and if it works for you like it did for me all will be good.

Go to the Installing ClassicPress page https://docs.classicpress.net/installing-classicpress/#migrating-to-classicpress-without-using-the-plugin follow the instructions under “Migrating to ClassicPress without using the plugin”. When you upload using Filezilla or what ever you use there will probably be a few files that fail to upload. You will probably have to delete those files on the server using your ftp program and then upload the files again and they should be successful. Now try your site and it should be working. If not, ask for help here. I’m sure someone more knowledable than I will be glad to help you.


#2

Thanks for the post. Would be good to work out why 5 of them worked but 2 failed. Is there anything different with those 2 that may have caused a conflict?

I’m sure the team would like to make the migration plugin as reliable as possible, so any more details you can provide would be very helpful.


#3

@ [BMJinGA]

I also use this method for migration
Migration via migration plugins if migration fails
who knows why
it can do more harm than good


#4

@BMJinGA Great that 5 websites went fine.
Regarding the other 2 can you check the error logs to see if there is any valuable info that you can share.


#5

For whatever reason the file couldn’t be over written, even with Filezilla. I had to delete the file and replace it. And because of that it caused the plugin to error out and stop. Without all the files being replaced the site just quit working. I was in a hurry to get the switch completed so I didn’t spend time trying to figure out what was causing the problem. I just got the files replaced and it worked. It very well could have been some file permissions that got changed through time with the changes to the sites. Some sites have went through a lot of changes in the past 20 years. They were all originally hand coded before I switched over the WordPress.

Here is some info from one of the error logs that might be of some help-

Got error ‘PHP message: PHP Warning: copy(…/wp-includes/widgets/class-wp-widget-custom-html.php): failed to open stream: Permission denied in …/wp-admin/includes/class-wp-filesystem-direct.php on line 243\n’, referer: http://…/wp-admin/tools.php?page=switch-to-classicpress

I work a full time job, maintain the websites on the side and we’ve been restoring an old, old house that we moved in to and we’re not done. So I may be slow at responding back. So be patient with me.


#6

No worries. Thanks for the extra info. It could well be a permissions issue.

Good luck with the renovating. I’ve been through that and it’s an endless job. :cold_sweat:


#7

Yep, it looks like this was the permissions error that prevented the update from completing.