White on white in the editor

I’m on this since 3 hours now and cannot find a working solution. The problem as such seems to be old, it has been reported since WordPress 3.3.1:

In short: When trying to edit an article, in the editor the text is white on white, but only since a few days. It was reported to me as admin for a blog on Dec 3rd. The problem does not apply when trying to edit pages, only with articles.

My other ClassicPress blogs (on another host, but with identical configuration and software versions) do not show this behaviour. I have compared file ownerships and permissions of the affected blog with my other ones and could not find any differences. So I’m not sure how to reproduce that problem.

I had followed the options from the linked website as far as I could do that. Deactivating plugins did not help; the blog has the following plugins running:

  • All-in-One Event Calendar
  • Edit Author Slug
  • Social
  • Subscribe to Comments Reloaded
  • Thin Out Revisions
  • Wordfence Security
  • WPS Hide Login
  • YOP Poll

All of these are up-to-date.

I am not willing to install some Google stuff as suggested by the linked website.

I have made the change in the wp-config.php, as suggested; but of no use.

I have installed and activated the plugin „Advanced TinyMCE Configuration“, but of no use. So I deactivated it, but it’s still installed.

System information:

  • OS: Devuan 3 (Beowulf), running cron-apt every night
  • Webserver: nginx-full_1.14.2-2+deb10u4_amd64
  • PHP 7.3.31-1~deb10u1
  • ClassicPress 1.3.1 running Twenty Twelve theme

EDIT:

  • I forgot to mention that the editor shows „0 words“ under those postings, even if they are not empty.
  • Checked for the last updates on that server, but the last one before was libnss3 on Dec 2nd, that should not be the cause.

Is the text white on white in both the visual and the text editor?

It’s in the text editor, and I cannot change to the visual editor.

Have you looked in the browser console to see if it’s showing any errors?

Found this (domain hidden with $DOMAIN):

JQMIGRATE: Migrate is installed, version 1.4.1
downloadable font: rejected by sanitizer (font-family: “dashicons” style:normal weight:400 stretch:100 src index:0) source: https://$DOMAIN/wp-includes/fonts/dashicons.eot
downloadable font: rejected by sanitizer (font-family: “dashicons” style:normal weight:400 stretch:100 src index:0) source: https://$DOMAIN/wp-includes/fonts/dashicons.eot

Dash icons, I guess that is why I cannot change from text to visual, but it does not explain why the text in the text area is white on white.

There must be a CSS rule somewhere that is setting the text to white in the editor. Have you looked in the CSS Inspector part of the browser’s developer tools to find it?