1.7.1 results in error requiring Connection Information

The notice I get does not do anything. I urgently need to roll back to 1.7.0 and can see no way to do this. I backup wp-content but never thought I might need to backup wp-admin

Expected behavior

I should be able to access my site!

Current behavior

Instead of access, I am asked for information about FTP access.

Possible solution

Trying to work out precisely which details the form requires. Cancel does not cancel! No submit button. What am I supposed to do?

Steps to reproduce


My site does not seem to be available, which is not ideal!

I nuked everything and then uploaded a freshly downloaded copy of 1.7.1 and it seems to have worked, for now. But I would love to know what the problem might have been.

This was a minor release. It shouldn’t have caused any issues, especially nothing major. Since a clean install of 1.7.1 worked, my best guess is something either got corrupted during upgrade or an issue with permissions.

The FTP screen will come up when CP can’t write to disk.

Most likely something happened during upgrade and files were either corrupted or didn’t copy correctly.

A fresh install is the correct way to fix the issue.

Would the upgrade alter the permissions, even temporarily?

The FTP screen had no Post button or similar, and the Cancel button did nothing.

How do I opt out of automatic upgrades? I want to make sure I have a fresh backup of wp-admin etc.

To disable automatic updates put this code in wp-config.php:

define( 'WP_AUTO_UPDATE_CORE', false );

Files in wp-admin/ and wp-includes/ don’t need a backup as they should be the same as those in the release zip file.

For the last 3 weeks or so, many Internet Service Providers are under extreme DDoS attack and have worked hard to remedy the issue.

Some of those services most probably have reversed their configuration settings at such level that could possibly alter their user:group standard user settings to their server engine’s defaults.

It had happened lots of times in the past and won’t be the last, especially in shared hosting services.

Feel free to witness some outages / attacks at https://www.thousandeyes.com/outages/

I’m not saying it’s not a corrupt file case like @viktor suggested, but if the aforementioned case coincided with your upgrade procedure, then yes that file got corrupted unfortunately during the time of attack…basically they have interrupted the upgrade procedure leading to messed up files between old version and new.

Thanks for the link. Interesting, in a morbid way.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.