Clicked Switch and nothing happened

Tried to do the switch on a locallly installed testing version of my live site. Got the mostly green checklist on the screen shot above. On pressing switch button, page reloaded after 20 - 30 seconds only showing the theme and Elementor notices. There was no indication of the plugin doing anything and there was no switch. Site seems ok, everything still appears to work. The site is loaded on my Synology NAS if that makes a difference.

Hi @Roger_Smith, this sounds like it is probably a conflict with another plugin that is installed on this site.

Please check https://docs.classicpress.net/installing-classicpress/#plugin-conflicts first and make sure you’re not running any of the conflicting plugins we already know about.

Can you post a list of the plugins you have installed?

Can you post a screenshot of the screen that appears after you click the Switch button?

This was a very recent install so not many plugins.

The following were installed and activated:
Black Studio TinyMCE
Elementor
Elementor Pro
Recent Facebook Posts
Switch to ClassicPress
Testimonial Basics
Twitter Button by BestWebSoft
WordPress Importer

The following were installed but NOT activated:
Aksmet Anti-Spam
Photo Station Tinymce Plugin
Photo Station Wordpress Plugin** (Both of these are Synology NAS automatic inclusions)

I deactivated each one in turn - except Switch - but there was no change.

My theme is City Logic, which I swapped out for Elementor Hello theme, a bare bones theme for use with Elementor. This change did not allow me to switch either. I changed the theme to twenty seventeen. Still no.
I think it must have something to do with it being on a NAS, but what I have no idea.

Screenshot is after 10 minutes of pressing switch.

NB Just seen on the conflicts page the section for migrating to ClassicPress without using the plugin. I have resisted doing this to try and figure out what has gone wrong with the plugin, which may be of assistance to others.

I had a migration hang when that bottom icon was amber too. I used the FTP method instead of the plugin and everything worked fine.

In fact I never bothered with the migration plugin again and did all my site switches by FTP. If you have the option to use FTP, I think it is a much safer route to take.

Just remember to remove the file and folder from the unzipped content first, as explained.

@Roger_Smith who is your hosting provider for this site?

Would you be open to letting us take a look at the site? If so, I’ll send a private message here.

Never mind, you already answered this.

Anyway, what I am trying to understand here is why the site says that some core files were modified. The problem you’re having with the migration is probably related to that.

I think I may go ahead with the migration via FTP just to get this moving along. Maybe it is the amber alert, but as a new install I was at a loss to see which or how the core files have been modified. I’ll give a go later and report back.

Ok, that will probably work, but it would be nice to try to figure out what happened here so we can prevent the same problem for other users.

@james @Roger_Smith

It happened me the same today with a site hosted in Siteground.

I can confirm that is a plugin conflict, but will have to replicate it again to figure out what was the plugin that caused that. Will update this topic when I have that info.

1 Like

That was fun. :confused: Did the non plugin upgrade and all I got was a php page.

<?php /** * Front to the ClassicPress application. This file doesn't do anything, but loads * wp-blog-header.php which does and tells ClassicPress to load the theme. * * @package ClassicPress */ /** * Tells ClassicPress to load the ClassicPress theme and output it. * * @var bool */ define('WP_USE_THEMES', true); /** Loads the ClassicPress Environment and Template */ require( dirname( __FILE__ ) . '/wp-blog-header.php' ); Uninstalled / reinstalled Worpress from the NAS about five times but Classic Plug seems to have stuck, even though I have deleted the folders multiple times, all I get is the same read out.

Ok… This is what happens when your web server is not set up to serve PHP files correctly.

It worked fine with the fresh install of Wordpress. I was able to access everything and log in. Did the change and am now here.

1 Like

OK, I’m glad to hear that this was resolved after trying again from scratch.

Don’t know if it would apply here, but any setting that stops WordPress core update, including any of the following in wp-config.php can have an effect on the migration, from my experience.

define( 'AUTOMATIC_UPDATER_DISABLED', true );
define( 'WP_AUTO_UPDATE_CORE', false );
define( 'WP_AUTO_UPDATE_CORE', minor );
1 Like

I did a test migration of my main site using the plugin and i had define( ‘WP_AUTO_UPDATE_CORE’, false ); in my wp.config file.

And it went okay?

Doesn’t that code simply stop your site from checking with WP for updates?

It shouldn’t get involved in the migration process.

It doesn’t stop checking. With that, you still get notifications of updates. When I first began the migration, they did have an effect.

I don’t know exactly how they have an effect, but from what I experienced, they can. Better to remove them just before migrating, or that was my experience. Plugins that stop auto update had same effect, blank page. Had to deactivate them.

Just sharing my experience.

More details about my plugin conflict that stopped the migration process, the migration goes without any issues when I disable these 2 plugins:

1- Disable All WordPress Updates
2- WP Downgrade | Specific Core Version

Since I can replicate this situation will check later today with the Core team, if we can get to a final conclusion about this and add those plugins to the plugin conflict list.

p.s- I was with WordPress V5.0

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.