Failed theme install - checksum issue/gravatar/wp.com cookies

Expected behavior

When clicking install on a theme it should install

Current behavior

As per screenshot, the theme install is not going through:

Possible solution

Looking up in the console (chrome browser)

I noticed 24 cookies errors related to sites on my WP.com account. Since the site admin has the same email as WP.c om account I thought Gravatar could be the issue and installed “Disable User Gravatar” plugin. That solved the issue.

Steps to reproduce

Set up a ClassicPress site and:

  1. Have the admin of the site use the same email as WP.com account
    2.try to install theme
  2. correct the errors by disabling gravatar

Context

Note that I can’t just disable Gravatar because I need it. Like me, many people may have a gravatar and also some CP sites affected by the very same gravatar issue.
For reference, there is a petition to disable gravatar by default: https://petitions.classicpress.net/posts/8/disable-gr-avatar-by-default

1 Like

Sorry but I’ve not been able to reproduce that effect.
Do you have something more in the logs?
Simone.

Edit: I can see the same warnings about cookies.

2 Likes

I am going to check better tomorrow morning to understand what is going on and why disabling gravatar did the trick. Thanks for checking @Simone.

2 Likes

Those warnings

are a common thing in Chrome when loading any 3d-party javascripts (e.g Yandex.Metrika, social networks widgets, live chats etc.). As far as I know, this Chrome requirement is rather new and the most part of services don’t support the cookie attribute for now. I face those warnings on almost every local website and this causes no real errors, they are harmless. So, this might be an occasional correlarion, not the reason.

2 Likes

So these were a cookie connected to gravatar. And it’s chrome.
Themes checksums are another thing, but resolved as soon as I installed a plugin to get rid of gravatar.
I am going to try to replicate taking out the plugin and reenabling gravatar. If the issue occurs again is most likely the plugin does something else in addition to gravatar removal… Thanks @norske for clarifying about cookies.

1 Like

Ok. I tried to replicate.
Disabling the gravatar disabler now theme install performs without hickups.
It seems a “one time issue”.
It may be related with Aruba issues maybe.
Site is very new, has a bunch of CP specific plugins and I have not configured them yet (started to work on it, but got sidetracked…). If it was a php conflict I would have had a notice, my experience with JavaScript errors says that it’s unlikely JavaScript may cause this. And console just warns me about those cookies.
Aruba logs just shows nothing relevant.
I think I have no clue but it solved itself?

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.