Fresh install, edit post and media library don't work

Hi all!

I made a fresh install with ClassicPress 1.7.1, no problems there. I imported some posts from a wordpress site, just for testing, didn’t discover anything strange. Tried to upload some images, both through the multi file uploader and the browser uploader, but that didn’t work. No browser window were opened.

So I tried re-installing CP through the admin, but nothing changed.

Next step. I deleted everything, including the database and started all over. The installation doesn’t indicate any problems. Then, whithout changing anything whatsoever, I tried the media uploader. The multi file uploader still not working, the browser uploader does, but the files doesn’t show up in the library (they are uploaded, I’ve checked).

I also tried to edit the example post Hello World, but the editor is completly empty. Oh, and the editor’s “add media” and “edit permalink” buttons don’t work either.

I’m ready to roll up my sleeves, but don’t really know were to start. Installation is on Apache/Linux with php 8.1. Chrome browser.

I’ll be thankful for any clues!

Hi, strange your question hasn’t been answered.

I’m no expert, but I’m not sure 1.7.1 supports PHP 8.1

Try going back to 7.4 and see if the problem persists. If it doesn’t, then I think 8.0 does work.

Someone will be bound to reply with a more official answer.

CP 1.7.1 supports PHP 8.0 only. If you need PHP 8.1 support, consider our upcoming v2.0. It’s not out yet, but you can test nightly version. It’s rather stable. Many of us are running it in production.


Well, that would be a simple solution that I didn’t think about. I’ll revert the PHP version just for confirmation, but I’ll probably head over to CP 2.0 after that. Since it seems to be stable enough, why not?

Many thanks to both of you!


Just want to let you know changing PHP version didn’t solve the problems, the behaviour was exactly the same. I tried both 8.0 and 7.4. I don’t know what was wrong, maybe the installation zip file was damaged, from time to time my internet connection is bad.

But nevermind! I removed everything, and installed CP 2.0 instead. Seems good so far! I will report any issues I might find, if any.


Just FYI: I’m running PHP 8.2.13 on CP 1.7.1 with no problems.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.