Good bye Elementor?

From v2.8 the Elementor team have decided to only support WP v5.x onward so I guess it’s time to say good bye, Elementor. It was nice knowing you!

Or is it?
Are we adventurous enough to fork and maintain a pre 2.8 version for CP?

Do you currently use Elementor with CP? If so what are your views on the pending changes?

4 Likes

This is not what I wanted to hear!

I have just bought another, 3-license lifetime addon pack, from a 3rd party provider. That makes 7 licenses I have paid for so far, and they are not cheap.

If I have to freeze Elementor at 2.7.x that is not going to be a good long-term solution. It would also mean I should think about trying to get a refund for those licenses I bought only days ago.

I hope ClassicPress is not going to end up being a game of “Whack-a-Mole”, as more and more developers drop WP 4.9 support for their plugins. We can’t fork them all.

3 Likes

I don’t think we need to play Whack-a-Mole or fork everything. We can instead support those developers who make clear that they are supporting ClassicPress.

In the case of page builders, one of the Beaver Builder devs has already made it clear on these forums that they will be supporting ClassicPress. See "Must Have" Plugins List

Obviously, changing from one plugin to another takes time and work in the short term. But, if it also provides a long-term solution, then it will save both in the long run.

2 Likes

Yes, I read that. I was unaware though that Elementor had already said they would not support ClassicPress.

I have applied for a refund for the latest licenses I bought. Will see how that goes.

2 Likes

@zulfgani

I just got this reply from Elementor:

Thank you for contacting us.

We are adding compatibility with WordPress 5.3 on Elementor 2.8, I am not aware of dropping support for WP 4.9
https://github.com/elementor/elementor/issues/9672

Could you please let me know where you got this info so that we can authenticate it and check with the developers if needed?

Where did you read that?

4 Likes

It’s in their 2.8-beta-2 version (in the code, not a statement) - plugin will not run if WP version is bellow v5.x (tested locally) unless that is subject to change!

3 Likes

Thanks. I have let them know.

2 Likes

I got another reply after questioning them about the minimum version figure:

Thanks for contacting us.

I checked it out with the developers.

It is only in beta, the stable version will support WP 4.X and higher

So there is still hope.

6 Likes

Let’s hope they stick to that and not pull a WooTrick in the near future! Then again, it would be better to pull the trick than just sneak it in when no one’s looking.

3 Likes

Obviously they won’t keep it backward compatible forever. But they are at least aware we exist.

I’ll still wait for the stable release before being convinced though.

3 Likes

I’ll update the thread if they stay true and come through on that promise.

My concern is that they’ve not acknowledged and stated it publicly to the comment on the issue linked to above.

Also why have it in the first place as it has excluded all of those on the v4.9.x branch from beta testing it.

3 Likes

Another little surprise for v2.8. You will now have to connect your site to Elementor’s in order to use their templates even the free ones.

2 Likes

Yes, that’s not going down too well with either users or reviewers.

Also, content hidden on different devices is still showing in the preview, but greyed out. That makes the live preview cluttered.

Don’t you just love progress?

4 Likes

Lol yeah. Never mind the old adage of “If it’s not broken why fix”, it’s in with the new “It’s perfect, let’s break it and then patch it up” :upside_down_face:

I was hoping to start adopting my themes to work with the Pro’s theme builder but now I’m having second thoughts

3 Likes

Seems the left hand doesn’t know what the right hand is doing. While Elementor said they will support WP 4.9.x their developer has said otherwise:

Elementor supports the last 3 versions of WordPress (Current - 5.3, 5.2, 5.1, 5.0).
WordPress 4.9 was released on November 16, 2017, and since then it has progressed and evolved in many fields, but most importantly in terms of minimum requirements and new functionality.

We try to align with them and to provide our users with the best experience.

Thanks anyway.

So I guess the answer is no, not yes!

2 Likes

Probably safest to assume it’s an ex-plugin as far as CP is concerned. At least Beaver Builder has done the right thing :slight_smile: But I just wish that BB would introduce a single-site pricing option though as not everyone needs or wants unlimited sites and at $99, it is quite pricey.

3 Likes

Well, that wraps up this chapter!

4 Likes

Exactly. The free version of Elementor with free addons is normally enough for the average user.

2 Likes

Which doesn’t inspire me with a lot of confidence in their product!

Does Beaver Builder not have a free version as well? I can see mention of Beaver Builder Lite.

2 Likes

It is a very basic plugin and would not be of much use.

I can still use Elementor by bumping the version number, but that’s not a good long-term idea.

3 Likes