How to fix the save of language in CP Beta 2

This guide/post is only for ClassicPress instance with issues on selecting and saving the language!

In ClassicPress Beta 2 we added our endpoint to download automatically the language for your instance.
The implementation has some problems because of a wrong file name that was not reconized from the system.

Current behavior with problems

One of the most common problem reported (on Slack and in the forum) was the installation from scratch of ClassicPress and choosing a language different from English (US) with CP that was not using the language choosen.
After the installation the language was still not configured correctly and was required a manual save like in this screen.

How to fix

We fixed the issue on our server so you don’t need any changes in ClassicPress code.
The only change that you need to do is:

  • Remove manually this files core-{slug}.po/mo from wp-content/languages
  • Reconfigure the locale from Administration/backend of ClassicPress in Settings->General

Automatically will be downloaded the file with the right name and saved in the right way.
For new installation of ClassicPress instead the problem is not already happening anymore.

If you don’t have this files core-{slug}.po/mo you don’t have this problem and you can ignore this thread

For more information you can find the pull request with all the details on


I don’t understand what you mean.

This is what I see there, and the themes and plugins folders also have similar files.


Do you have issues with the language chosen in ClassicPress? As I can see you don’t have this problem :slight_smile:

1 Like

5 posts were split to a new topic: ClassicPress does not support all languages of WP