I've broken my website

I have somehow managed to break my website.

We bought a domain, signed up to a host and then using their cPanel chose ClassicPress to design the site. Fastforward, site designed all set up ready to launch but there’s a problem - typing in our URL took us to an old school directory type page and from there we had to select the /cms directory to get into the site. I called our hosting service and was directed to make a change in the general settings of classicpress, essentially I removed the /cms from the end of the URL pointing or something, I cant remember what it was called. Its the URL above the one that you set to be how you get into the edit page?? and since then it just doesnt work at all. I get an oops that page cant be found notice and the site is all white with just text links. I can’t even get to the general settings area to try add that /cms but back to the URL.

Is there anyone who can help us? We are not complete noobs, but obviously not completely website savvy either.

###Expected behavior
My website should load like a normal website.

Current behavior

It loads with a white text based directory: (I could only add one pic so I put the next step’s one)

When you click the /cms it makes the page load like this:

Possible solution

I think I messed with a setting somewhere and I dont know how to get back there to fix it.

Please can anyone help me??
Al and Nik

1 Like

Your wordpress installation is in a folder called cms
In the admin settings>general the ClassicPress installation should have the cms at the end
victoriadronerepair.com.au/cms and the website address should be
I do not know if you are using www so could be either
https://victoriadronerepair.com.au or
You will probably need to log back in once you change this.

1 Like

Hi Mark, thanks for the reply

I’ve broken my brain, please could you explain how to get to the admin settings? I just get a ‘404 page not found’ error when I try to click ANY of the links on this page


or can i access it via cpanel somehow?

I am (currently) too scared that if I log out that I wont ever be able to log back in…

Yes trying to login redirects to the wrong address then the 404.
If i was fixing it I would change the info in the database directly via cPanel. You need to change the website url and the installation urls.
Can be a bit daunting if you are not used to it. Your hosting provider should be able to do it for you,
BTW In the cPanel settings you should turn of indexes, as the contents of any folder with out an index file are visible.

Thank you so much. We will call them and hopefully get it sorted. Thank you!

Yes, as Mark says, the problem is that ClassicPress has been installed in a directory called cms off the root web directory (probably public_html/cms).

Personally, I think the best fix is to move the files from cms into your root web directory, after taking a backup of everything first of course.

In the root directory, there should also be a file called .htaccess which should contain, as a minimum:

# BEGIN ClassicPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END ClassicPress

You may also want to add the following line to prevent files from being displayed:

# Disable Directory Browsing
Options All -Indexes

If you’ve got access to a SSH shell and if the WP-CLI is installed, you could then run the following to change the URL of your site.

wp search-replace http://victoriadronerepair.com.au/cms http://victoriadronerepair.com.au

or, if you want www:

wp search-replace http://victoriadronerepair.com.au/cms http://www.victoriadronerepair.com.au

And for good measure, add the following lines to your wp-config.php file:

define( 'WP_HOME',    'http://www.victoriadronerepair.com.au' );
define( 'WP_SITEURL', 'http://www.victoriadronerepair.com.au' );

and change the appropriate settings in CP admin.

If in doubt about any of the above, speak to your hosting company first.

1 Like

This was bad advice from your hosting provider, you should let them know that their advice broke your site.

Also, for what it’s worth, this is not a ClassicPress-specific issue: the same thing would have happened on any version of WordPress.

Cheers, I didn’t know where to start with trying to get it fixed. I’ve contacted our host and hopefully they can sort it out for me.

1 Like

Sweet thanks! I’ll give that a go!

1 Like

Hi again, Is there any way for me to access my classic press website any other way? Like is it saved to my profile or something? Long story short, hosting provider kindly restored the site to the day before… when the classic press site didn’t yet exist (yes I am crying). Hoping to salvage at least the text content that I had typed up - all the privacy policies etc. and then I’ll redesign the site from scratch again. Thanks a mil for all your support.

Unfortunately, you have become the victim of breaking the first rule of computing - “Backup”.

In cPanel there is a tab called “Backup”. This enables you to download a compressed version of your website (Home Folder) and database.

As you build a website, you should make backups using that at regular intervals. You then have them on your computer should you need to restore your site to the last backup that worked.

Unless your hosting company has a more recent backup of their own, then your site is gone for good.

I suggest you contact them and explain the situation. Maybe you will get lucky. Someone else here may have another idea, you never know.

But don’t beat yourself up over it, we have all done it at some stage. It’s one of those lessons we usually learn the hard way.

Regarding the /cms folder, I had a friend who recently used Softaculous to install Drupal and it was forced into a folder.

The reason being, the installer saw there was already an index.php file in the Home folder.

I don’t use the installer, so don’t know if you get an option to overwrite it instead. You currently seem to have an “Under Construction” file in there. So you may have to delete that and the .htaccess file first before your ClassicPress installation will go in the Home folder, where it belongs.

Regarding where to put the ClassicPress installation. I always put the installation in a folder.
It does not affect the sites operation, keeps the root directory clear, and, if at some point, you are wanting to do major updates or potentially site breaking changes you can work on a second version of your installation in parallel to the first, and then swap over very easily when ready.
It can work out much easier and quicker than creating a local version, especially for a site with a lot of content.
If I remember correctly WordPress used to install itself into a folder called “wordpress”

1 Like

The second rule: Never trust your hosting for backups. Never. If you don’t have a backup outside hosting, you don’t have a backup.

The third rule: You will sleep better, if you have 2 different backup methods (plugins), backuping to the 2 different storage providers. Paranoid? A little bit. But your sleep will improve.