Keep ClassicPress & WordPress versions separate in plugin readme header

Right now the WordPress plugin readme header can have these elements (among others):

Requires at least: 4.9.5
Tested up to: 5.4

(the numbers shown are just examples)

These are used by the WordPress API when it returns plugin lists on the plugin-install.php admin page, to advise admins whether plugins are likely to work with their installation.

As I understand it, the unofficial but useful Code Potent Update Manager plugin specifies that the ‘Requires at least’ number should be the required ClassicPress version, but that the ‘Tested up to’ number should follow WordPress versioning (for example 4.9.99). I’m sure there’s a good reason for this.

However, before the official ClassicPress plugin directory is built, I’d like to suggest that CP and WP versions are kept separate in the readme header, so that plugin authors who want to support both platforms can do so with one zip file.

For example, this is how it could work:

Requires at least: 4.9
Tested up to: 5.4
CP core min: 1.1.0
CP core max: 1.2

The first 2 lines above would be read and used by WordPress installations, but ignored by ClassicPress. The last 2 lines would be ignored by WordPress but used by ClassicPress.

Note that the last 2 lines are named very differently (while their purpose is still obvious) to avoid any possibility of the WordPress API using them.

And to maintain consistency with WordPress, if the CP core max value contains an “X.X” version number, it would be interpreted to mean “X.X.Anything”.


Read-only archive: https://petitions.classicpress.net/posts/211/keep-classicpress-and-wordpress-versions-separate-in-plugin-readme-header

Author: zigpress

Vote count: 6

Status: open


Comments