"Must Have" Plugins List

Fluent Forms doesn’t seem to have any payment processing integrations; maybe because they have a separate form product for that? (WPPayForm Pro)

1 Like

Due in the next quarter according to their Facebook group admin. You won’t need to use the other plugin.

2 Likes

Just had a response from WPManageNinja, makers of the Fluent Forms plugin:

“The dev team confirmed they will continue the support for ClassicPress always.”

Result :slight_smile:

9 Likes

Excellent. Thanks for following that up. Have given Fluent Forms the big green tick.

2 Likes

Updates Manager / Notification Manager / Auto-Update Disabling plugin: Yes, there is a need for that, because clickyclickyclick-happy clients who JUST LOVE :heart_eyes: to install updates without giving it any further thoughts :scream: :face_vomiting:

What I’ve tested so far and can report as “working”:

  • Easy Updates Manager - has some nasty nag screen for its “suggested” plugins included, with a 6-month / 12 month dismissal option, but aside of that, its working flawlessly. Also works (so far) on Muiltisite
  • Webcraftic Updates Manager - works decent, too, but leaves out too many notices; but its base functionality, ie. disabling / enabling auto-updates globally or individually per item, is working as expected; Multisite: Its suggested to use Multisite Plugin Manager to individually enable or disable the plugin per site

cu, w0lf.

1 Like

Just like to add Beaver Builder to the list as a page builder. Works 100% on CP, and always will.

5 Likes

Has beaver builder said they will be supporting CP?

I’m one of their developers, I should know :wink:

6 Likes

Just making sure :wink:

2 Likes

That’s great news. Any chance you could add words to that effect on your website and share the good news?

1 Like

I’ll try and remember to add something in the readme for .org and I’ll have word about adding something on the site

2 Likes

That’d be great. Just as long as it doesn’t put you at risk of being blacklisted by WP. :slight_smile:

1 Like

Is there a history of wp blacklisting plugins that say they also work on classic press then?

1 Like

I haven’t heard anything along those lines. And many thanks for your support Simon. A page builder was one of the big areas we needed to cover.

2 Likes

There’s certainly a history of posts being removed from the forums if anyone should happen to mention ClassicPress.

I’m sure it used to be the case that WP didn’t like ClassicPress being mentioned in the readme either but I’ve just noticed this: https://wordpress.org/plugins/zeno-font-resizer/, this https://wordpress.org/plugins/custom-taxonomy-order-ne/ and, of course, this https://wordpress.org/plugins/zigwidgetclass/, written by @zigpress, a fellow member of the CP community.

So it looks like you should be OK but maybe @zigpress could confirm??

3 Likes

Thanks. Have added those in with summary of your comments.

1 Like

I’ve had plugin repo support questions removed for asking about ClassicPress, but never had a plugin removed or suspended for mentioning CP in the readme.

Though to play safe, when I submit a new plugin to the repo, I leave out any mention of CP, then add it into the readme with the next release.

3 Likes

I will ask mika but I’m sure a link is fine in the readme

3 Likes

@Pross - this comment was just posted on Slack:

“I used beaver builder for one of my experiments in learning to build a site with WP. And compared to elementor/Divi free versions it seemed to me the best. It was easy for me to use/understand it. And to say I am not a fan of builders but I appreciated it, it says a lot. Happy to see them onboard.”

3 Likes

Hey guys,

Just want to add Meta Box - a lightweight yet powerful custom fields plugin, and Slim SEO - a non-bloated SEO plugin to the list. They’re 100% compatible with ClassicPress.

6 Likes