New CP installation, how to import xml WP file?

I searched, downloaded a 0.7 plugin recommended for imports, but some error about lacking a header.

I have a new installation of CP, want to import a (actually several) xml files from WP installations. How to do that?


Is the Importer supposed to be functional? - #2 by viktor that is the correct importer plugin you mention.
It has already been reported not working (see this thread for more info), your description of the error you encounter seems different since they were importing “empty posts” that showed up in preview mode and you say the error is about lacking a header.

Can you let us know WP version you are trying to import from, PHP version of the WP site and PHP version of the CP site?
Also can you post an image of the error (if you see an error on the page, that is) so that we can try to reproduce to troubleshot?

@viktor could the two errors be the same thing/be related even if they seem to be a different issue?

Thanks for your reply.

Hackers got to my WP sites, so they’re gone. I had made xml backups back in February. Not sure what versions. Not sure where to find the php version on the server, but will look.

I’ve tried four or five importers. One gave a page missing error. Another just sat there spinning. Sorry I can’t be more helpful here.

1 Like

Just out of curiosity I was trying to see if the importer was “faulty” also for WP. And it comes out that the lacking headers/blank pages is an issue also exporting from WP and importing to WP.

See here for example (this user says the security header is lacking AND also mentions the blank pages so the two things seem to be related).

Might be worth understanding if WP people have solved this issue or not, and in case how they did it.

None of the importers I tried got me as far as installing pages or posts, not even blank ones. :frowning:

I was looking at the WP old releases of the importer. the importer v 0.7 is compatible with PHP 7.4.

Could it be a compatibility issue with the PHP? in WP the next release of the importer (that is the 0.8) introduces support for blocks and such AND also the compatibility for PHP 8, 8.1 and 8.2, this means that if the sites were on PHP 8 (could possibly be) and CP is on PHP 8 the importer might not be able to perform its job for that reason and also the other importers… I will spin up a test with PHP 8 and see if I get any errors related to that tomorrow morning.

1 Like

I tried v0.7 with CP 1.5.2, and the content was imported correctly. This site is using PHP 7.4.

Can you tell us what PHP and CP versions you’re using? Also, if you can, share the exact error code.

@viktor I already asked, the issue is they can’t retrieve the information about PHP version/WP version. that is why I will try to spin up a test with PHP 7.4 trying to migrate content to PHP 8 or above to see if the issue is that one. It seems lilkely since they upgraded WP version for v 0.8 (might be the plugin wasn’t working when migrating from PHP 7.x to 8.x - if ain’t broken don’t fix it…)

I still have the account. Would I find the php version in cPanel?

I think I found it: * PHP version: 7.3.32

7.3 is supported. Are you able to install any other plugins without any issues?

I didn’t try to install other plugins, after this failure. if I can’t import any content, CP isn’t going to be an option for me.

I tried to install the 0.7 wordpress importer again. I got this error message:

The plugin does not have a valid header.

Can you please try to download this zip file of the Importer plugin and try to install it please? I verified it works on my end:

The issue isn’t with ClassicPress. Otherwise it wouldn’t work on my end. Either the plugin zip file is bad or something locally to your instance of CP is causing it.

Either way, we’ll get to the bottom of this. Try the file above and let me know. If you’re still experiencing issues with the Importer plugin, send me private message here on the forum and I can take a look.

1 Like

Somehow I have two zip files of this importer, one larger than the other. The smaller one worked!


This topic was automatically closed after 3 days. New replies are no longer allowed.