New DigitalOcean OpenLiteSpeed ClassicPress 1-Click Application

The OpenLiteSpeed ClassicPress 1-Click Application is a quick and easy way to set up a new ClassicPress server on DigitalOcean.

The Application provides an interactive prompt to install and configure the OpenLiteSpeed Web Server, PHP, MySQL Database, ClassicPress, and the LiteSpeed Cache plugin. After the setup is complete, your new ClassicPress site is ready to go.

What is OpenLiteSpeed?

OpenLiteSpeed(OLS) is an open-source web server (similar to Apache or Nginx). It is feature rich and highly optimized for performance and security.

Its event driven architecture and flexible caching platform means your site will be blazing fast straight out of the box. You can always expect the latest and greatest server technologies - OLS is already available with QUIC and HTTP/3.

What is LiteSpeed Cache?

LiteSpeed Cache is an all-in-one caching plugin that integrates with LiteSpeed Web Servers. The plugin communicates with the web server to determine page cacheability and page staleness, maximizing your site’s performance while ensuring complete accuracy. In addition to the page cache, the LiteSpeed Cache plugin includes lots of other features, such as CSS Minification, CSS/JS combine, image optimization, OPcode Cache and more.


To use the OpenLiteSpeed ClassicPress 1-Click App, follow the instructions on our Quick Start Guide.


ClassicPress Community on Slack:
LiteSpeed Community on Slack:

Create a DigitalOcean Account

Affiliate Link: Sign up and get a $100 credit (ClassicPress will get $25 for the referral)
Non-Affiliate Link: Sign up


I’ve just been through the process which is super-easy. Thanks for all the work on this. One question though, the CP installation came with a bunch of plugins pre-installed. Only LiteSpeed cache was activated, but why do we get the others (including Jetpack!).


That shouldn’t be happening. The only plugin it should install is the LiteSpeed Cache. I suspect that’s a DO thing rather than a LiteSpeed thing as I wrote the ClassicPress parts of the 1 Click Application and I know for certain that the only plugin it installs in the cache plugin.

Out of interest, did it install all of those additional plugins in your screenshot or have you added some of your own?

And, shock horror, what’s All In One SEO Pack doing there?!?!?! :open_mouth: :wink:

1 Like

That’s what I saw after I followed the install process and opened the admin for the first time. I haven’t added anything.

Exactly. And what’s Jetpack doing there!!! (the last thing I would want).


Yes, JetPack is definitely a no-no. In fact, I would say they all are really with the exception of the cache plugin. Just teething problems though.

I feel sure this must be a DO thing but we’ll need @LiteSpeedTech to confirm this.

1 Like

On the plus side, I’m just investigating the OpenLiteSpeed admin area. Looks great. Lot’s of stuff to play with. :smiley:

I’d like to work out how to add in more sites on the same droplet. Looks like you can set that up through virtual host area. :+1:

EDIT. Nope, it’s beaten me. I’ve followed tutorials and tried copying the included example but I can’t make it work. Oh well… I guess I’ll just stick with shared hosting and leave it to the people who know about this stuff.


Hi @ozfiddler

Thanks for giving it a try! I’ll try to get the additional site script up and running when I can. We do have one, but it’s just not built for ClassicPress yet.

Regarding the plugins, that was our build script. Those tend to be popular plugins that users will install, so we just installed and deactivated them. These will be removed on the next release.



Hi Kevin,

If there’s script that takes care of it that would be great. Adding in extra web domains to a server must be one of the most commonly needed jobs, and I’ve never understood why it has to be so complicated and fiddly.

Yes, if those plugins could all be removed it would be good. Otherwise the installation experience was very good.


This is really exciting to see, finally a simple way to spin up CP on DO :slight_smile:

Thank you @LiteSpeedTech and @1stepforward for all your work on this!


I’m currently working on the script to add additional domains. It shouldn’t be too far off now.


That would be great. I must have tried 50 different ways over the last few days… wasted more time than I should on it. I get the green light in the console but all I ever see is a 404 page.


51st time lucky. :slight_smile:



We just uploaded the vhsetup script on GitHub (search for ‘ls-cloud-image’).
We did some brief testing on it, but if you’d like to give it a try, let us know how it goes!



4 posts were split to a new topic: OpenLiteSpeed CP vhsetup

Forgive me if this is a stupid question: I am trying to use CP with OpenLiteSpeed using the digitalocean 1 click install. Following the directions here for granting my ftp user access to the html folder ftp: chown -R www-data:wordpress /var/www/html and it just doesn’t seem to work. I realize this is the wordpress instructions but the CP instructions don’t explain how to grant my sftpuser access
Can anyone tell me how to safely grant access to my sftpuser?

I have never used what you are using. But on Linux, the command should be

chown -R www-data:www-data /var/www/html