OpenLiteSpeed CP vhsetup

Continuing discussion from New DigitalOcean OpenLiteSpeed ClassicPress 1-Click Application


I can’t find it. It’s somewhere on this page? https://github.com/litespeedtech/ls-cloud-image

OK - found it. I guess I have to download the vhsetup.sh file.

This is my experience so far.

  • Tried to copy the file and upload. Got error message. Google tells me that Windows adds some unreadable line ending. Download the whole repo and use that file. Works.
  • First time through fails because I haven’t got the correct folder created in var/www. Create that folder.
  • Second, third and fourth time Lets Encrypt fails even though domain is pointed to IP.
  • Fifth time through say N to Lets Encrypt, seems to progress until it says “Install Wordpress Y/N” - I said Y, and it asked for confirmation and I changed my mind and said N. It then asks me to choose between WP and CP, but says the application I have chosen is WP. No way to get out of that… if I say N it loops. Cancel and start again.
  • Sixth time through say no to WP and then get CP option. Seems to work and tells me “Setup finished”.
  • Visit site url… 404 page.

This is why I use shared hosting. :grimacing:

OK - I just started again from scratch using a different domain name. This time it worked! :confetti_ball:

I think there must have been remnants of stuff in there from when I was trying before and that was messing up something somehow. I guess. :man_shrugging:

This time it created the folder in var/www automatically.

The line about “Choose whether to install WP or CP” only comes up if Lets Encrypt is successful. Otherwise it just goes straight to “Do you want WP”. And you can’t change your mind.

So maybe just needs a bit of tweaking of the option flowchart. But I can confirm that it works.

1 Like

Please check doc here: https://docs.litespeedtech.com/cloud/classicpress/#how-do-i-create-additional-virtual-hosts

for the setup method.

CLI mode should be easier for you, e.g.

Setup new Virtual Host and Listener:

/bin/bash <( curl -sk https://raw.githubusercontent.com/litespeedtech/ls-cloud-image/master/Setup/vhsetup.sh ) -D www.example.com 

Setup Virtual Host, Listener, Let’s Encrypt Cert Apply, Force HTTPS and ClassicPress installation

/bin/bash <( curl -sk https://raw.githubusercontent.com/litespeedtech/ls-cloud-image/master/Setup/vhsetup.sh ) -D www.example.com -LE [email protected] -F -C

Best,
Eric

5 Likes

I’d suggest reporting this separately at https://github.com/litespeedtech/ls-cloud-image/issues if it is still an issue.

Hi @james,

Please check my test result.
For manual mode:

CLI mode:

/bin/bash <( curl -sk https://raw.githubusercontent.com/litespeedtech/ls-cloud- 
image/master/Setup/vhsetup.sh ) -D www.example.com -C
Vhost created success!
Setting ClassicPress
Install litespeed-cache.zip
ed exist
Finish ClassicPress
ClassicPress downloaded, please access your domain to complete the setup.
Setup finished!

No issue from my testing.

Best,
Eric

1 Like

Hi Eric,

That line “Please choose whether to install WordPress or ClassicPress” is not displayed if you say yes to Lets Encrypt and the process fails for some reason. It went straight to “Install WordPress?”.

Can you try this… when it says “Install WordPress? y/N” say yes initially but then change your mind at the next (confirm) stage and say no.

Hi,

So I tried “yes” to Let’s encrypt and it fails due to inaccessible. It then shows “Please choose whether to install WordPress or ClassicPress” question correctly from my testing.

If I choose WordPress first, I can still change my mind at the second question.

Best,
Eric

6 Likes

Thanks for testing Eric… that looks like it works perfectly. I don’t know what I did. Must have got myself in a muddle… it wouldn’t be the first time. :slightly_smiling_face:

3 Likes