PHP and db versions?

Didn’t see anything specific in the Get ClassicPress or install documentation, for: recommended PHP, MySQL, or MariaDB versions.

For website transfers, we match software versions, then help to upgrade if needed. For new installs, it would be good to be as current as possible. Since its a 4.9 branch are PHP versions 5.1 to 5.3 supported?

Can you add this info to the Get ClassicPress page and isntallation info (unless I missed it)?

Cheers
Avrom

2 Likes

We bumped the PHP version requirements (more details in the release notes for 1.0.0):

We should add those kind of details to the docs site. I know we have some work going on there at the moment (I think @ElisabettaCarrara is involved in it).

4 Likes

Tracking this here: https://github.com/ClassicPress/ClassicPress-Network/issues/66

We’re currently migrating the content of the docs site to a form that will be available for everyone to edit, and this will be a good first task to address after that migration is done.

In the meantime, yes, PHP >= 5.6 is a requirement that we enforce during migration and during installation.

Other requirements are the same as WP 4.9, so MySQL >= 5.0 or any version of MariaDB (since it was forked from MySQL 5.1).

5 Likes