PHP Error Log Viewer valid header error

The PHP Error Log Viewer gives the error “The plugin does not have a valid header” when I try to activate it. The same thing happened on both of my sites.

2 Likes

Thanks for the report, @NyssaTheHobbit. I was able to recreate this issue and have resolved it. My apologies for the inconvenience.

In case anyone else happens along (or searches the forum for “The plugin does not have a valid header” – the issue was that ClassicPress searches two-levels-deep in the plugins directory for files that contain a plugin header. In this case, I had added a header section to a couple of PHP files inside the /includes/ and /classes/ directories. Removing the line Plugin Name: PHP Error Log Viewer from those files fixes the issue. This is resolved in version 1.0.1 which is available at the link above.

Thanks again for reporting this!

5 Likes

Now it’s working. Thanks!

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.