I started getting this error in the Postie plugin whenever I tried to update it.
Fatal error : require_once(): Failed opening required ‘wp-includes/class-wp-oembed.php’ (include_path=’.:/usr/share/php’) in wp-content/plugins/postie/postie.class.php on line 24
The latest version requires Wordpress 5.3 meaning it is no longer compatbile with ClassicPress.
Anyone know of an alternative or fork to Postie?
Does it? According to the Postie overview on the WP Plugin directory it requires WP4.0 or newer. I have been looking at the forums of the plugin just now, it seems that they tried to make it compatible with WP5.3, but accidentally broke backwards compatibility. I think it was an accident.
Maybe you can revert to the previous version for now, and keep an eye out to see if they fix it.
Yes, looks like an unintentional bug. Hopefully they will fix it soon and keep backward compatibility.
And welcome @cwebdesign !
Oh, as an addition, If you don’t know how to download older versions of plugins, this is a great recourse that explains it: https://www.competethemes.com/blog/download-older-version-plugins-themes/
I think they are going to fix it shortly.
class-wp-oembed.php seems to be the renamed copy of
class-oembed.php (with just a better indentation ).
So as a temporary fix you could change it in
postie.class.php line 24.
Postie is fixed! Version 1.9.40.
WP Rollback is another good option - if you want to revert version of already installed plugins.
Thank you to everyone! I am loving ClassicPress and hope it will keep improving.