Postie Plugin no longer compatbile with ClassicPress

I started getting this error in the Postie plugin whenever I tried to update it.

Fatal error : require_once(): Failed opening required ‘wp-includes/class-wp-oembed.php’ (include_path=’.:/usr/share/php’) in wp-content/plugins/postie/postie.class.php on line 24

The latest version requires Wordpress 5.3 :frowning: meaning it is no longer compatbile with ClassicPress.

Anyone know of an alternative or fork to Postie?

1 Like

Does it? According to the Postie overview on the WP Plugin directory it requires WP4.0 or newer. I have been looking at the forums of the plugin just now, it seems that they tried to make it compatible with WP5.3, but accidentally broke backwards compatibility. I think it was an accident.

Maybe you can revert to the previous version for now, and keep an eye out to see if they fix it.

See: https://wordpress.org/support/topic/wordpress-5-3-error-notice-class-oembed-php-is-deprecated-since-version-5-3-0/

2 Likes

Yes, looks like an unintentional bug. Hopefully they will fix it soon and keep backward compatibility.

And welcome @cwebdesign !

1 Like

Oh, as an addition, If you don’t know how to download older versions of plugins, this is a great recourse that explains it: https://www.competethemes.com/blog/download-older-version-plugins-themes/

1 Like

I think they are going to fix it shortly.
class-wp-oembed.php seems to be the renamed copy of class-oembed.php (with just a better indentation :sweat_smile:).
So as a temporary fix you could change it in postie.class.php line 24.

Simone.

3 Likes

Postie is fixed! Version 1.9.40.

Simone.

3 Likes

WP Rollback is another good option - if you want to revert version of already installed plugins.

cu, w0lf.

1 Like

Thank you to everyone! I am loving ClassicPress and hope it will keep improving.

2 Likes