Problem with Plugin Submission Form

Tried to submit a plugin using “https://directory.classicpress.net/submission/plugin”. Clicking the “Submit Plugin” seems to do nothing. Using the Network Tool shows a fetch HTTP request was sent to “https://directory.classicpress.net/livewire/message/form.plugin-submission” and the following response received:

{“effects”:{“html”:null,“dirty”:[]},“serverMemo”:{“errors”:{“git_provider”:[“The git provider field is required when plugin type is 0.”]},“checksum”:“4a6db6d15fb26f661fec82389d0bc75531570a0fe8aca47c7486c04e4fda3e78”}}

However, nothing is displayed on the frontend. Further, both the repo and download links referred to github.

Tried again but now getting a different response:

{“effects”:{“html”:null,“dirty”:[]},“serverMemo”:{“checksum”:“1c0a74c692868a9f954721d75b49b1f64e57c599481224605e7e52e43d2f838a”}}

1 Like

Hi @magenta-cuda,

Thanks for reporting this. Tagging @wadestriebel as he’s the technical mastermind behind the directory.

…and welcome to ClassicPress! :slight_smile:

1 Like

Sorry about that! If you want to DM me your information I can make sure to get it up while we fix the submission form :slight_smile:

And welcome to ClassicPress :classicpress:

Tried this again and it is still broken. I think there are 3 problems with this page.

  1. It is rejecting what I think is a valid submission.
  2. The front end doesn’t show that the submission was rejected even though the server did return an error - “The git provider field is required when plugin type is 0.”
  3. The Sign in button takes you to a non-working page.

I really would like to submit my plugin. I hope you can fix this in the near future.

2 Likes

Hey @magenta-cuda still working on it, to be honest I haven’t had a ton of time this past week to take a look.

As mentioned above, if you send me through your plugin info I will ensure it gets up there. Thanks for your patience :slightly_smiling_face:

2 Likes

@magenta-cuda you can visit https://directory.classicpress.net/login now. Once signed in with your forum account, if you click on your profile photo you will be able to set up a Developer Profile and add your plugins via that. Let me know if you run into any issues :+1:

Login successful. But, server still returns the response (as seen in the browser network monitor)
{"effects":{"html":null,"dirty":[]},"serverMemo":{"errors":{"git_provider":["The git provider field is required when plugin type is 0."]},"checksum":"a5f547560897779e6638bc1b3e834f48a3833662199177c26912fbd6d2e51388"}}

However, the frontend does not display anything.

Here are the git links I submitted:

https://github.com/basic-tech/classic-shortcode-tester

https://github.com/basic-tech/classic-shortcode-tester/releases/download/1.2.3/classic-shortcode-tester.zip

I believe these are valid.

I am sorry but I do not know how to DM on this platform. How is this done? Is the repository for the plugin submission software public? Is the software done with PHP and JavaScript? I am quite good with PHP and JavaScript. Would it be helpful if I did a pull request?

1 Like

No worries! If you click on my profile photo you should see an option to “Message”, I have sent you one so you should see a notification on your profile photo on the right.

I have added your plugin and created you a developer profile, on the directory when you click on your profile photo you should see “Developer Profiles”.

Hi Wade,

I think the problem is actually quite simple.

The developer’s “Manage Plugin” form has a “Git Provider” field. This field does not exists on the “Plugin Submission” form.

1 Like

Yes it is, however we are in the process of deprecating that in favour of developers logging in to add their plugins. I forgot to add the Git Provider field to the “Submit Plugin” page, but we will be removing it shortly :slight_smile: