Shield security fatal error

EDITED TO ADD: tagging @Paul so he sees that.


Installing Shield Security I got a fatal error at activation.

I had installed a bunch of plugin and then selected them and bulk activated them (they were shield secirity, updraft plus and wp optimize).

Deactivating the plugin and activating again apparently made the fatal error go away.

Trying to uninstall and install again, the issue was not encountered.

The fatal was about a declaration that was not compatible on line 26 for the DBWriter hantdler (I was sure I could replicate and didn’t screenshot the error nor copied it).

I will keep an eye on this to see if it pops up again.

For reference: fresh install, plugins installed were cp dir integration, enriched editor and the above mentioned shield, updraft plus and wp optimize. theme twentyfifteen.

@Paul does Shield still support WordPress 3.7 and up? That’s what it says in WordPress repository, but checking the latest version, it uses functions from version 5.x.

@viktor thanks for checking this for me. the fatal error was not pointing at these but nevertheless this reinforces my idea we really need to detach completely from WP repos.

I use quite a lot of WP plugins that need first to rollback to previous versions to work with CP, namely with a plugin WP Rollback, at a site with WP latest version. Then I download the suitable rollback-version with plugin Download Plugin, and then upload to ClassicPress. (Or I just can make a copy of the directory of certain plugin rollback-version by FTP.) Amongst others is All In One WP Security, rollbacked to version 4.4.3.
Query Monitor shows that most of the rollbacked plugins use less server resources than the latest ones with WP.


I don’t want to use rollback versions for my sites. And this post is to report a bug to a dev who declared his plugin compatible with CP while apparently now they aren’t anymore.
And I am still waiting to understand if what happened was an occasional glitch or something I should be concerned about.

I tested Shield Security 15.1.6 on CP 1.4.2 and did not see any issues or errors. So far, the plugin seems to be working and compatible with the latest version of CP.

The issue might have been local, either related to a server config or a plugin/theme conflict.

1 Like

Thanks for the testing. After reading this thread earlier, I was wary of the update; just for the record: mine went smoothly.

@viktor just seeing your question there about WP 5.9.

We include functions for later versions of WordPress but they’re wrapped up to ensure that they’re not called if they don’t exist.

@ElisabettaCarrara - I believe wp optimise released an upgrade that included a version of the Monolog libray that was incompatible with ours. Our library version works on PHP 7.0+ but theirs was newer, only working on 7.2+. This caused errors for many people… I believe they rolledback their library upgrade to be more compatible. It actually also recently happened with WP Rocket, too.

Hope that helps.


The error never occurred again so I think that was the issue.
Thanks for checking.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.