Sites freezing in middle of update process

Let’s try to see what’s common between the sites that fail - plugins, size of uploads directory, that kind of thing.

I have an idea of what might be causing the problem, but it’s a bit esoteric so it makes sense to rule out the obvious stuff first.

Yes, I’ve been thinking along those lines too but I can’t come up with anything much. The only common factor is that they all run Shield plugin. But I seem to recall I tried deactivating it on one site when there was a problem and it didn’t help.

I use very minimal plugins. On most sites it is my own utility plugin and Shield. Of course my own plugin was the first thing I suspected but one of the problem sites doesn’t even have it installed.

OK, so maybe not plugins - what about themes? They can do everything a plugin can do.

I’m also quite curious about the amount of space the sites take on disk.

One is running a custom built theme that was made by someone else years ago. The others use my own theme that is basically GeneratePress.

Sites are at most 150MB. On the good hosting there is 1GB available, on the cheaper hosting they have 500MB.

Good hosting has 1GB RAM, budget is 500MB.

That’s a very big chunk of work. I’d suggest the time would be better spent on doing partial upgrades and making sure we get the signing right. We could spend a huge amount of time chasing after something that’s almost certainly a hosting issue, only to discover it’s something our changes don’t fix.

We’ve not changed the install/upgrade process more than strictly necessary for good reason - it may not be pretty, but it’s been debugged by brute force.I’d caution against changing anything unless we’re really, really sure we know what we’re doing and why.


I did some testing and I can not reproduce the issue from a clean install of 1.0.1 to 1.0.2, this is with server resources set at the minimum CPU, Memory and disk space.

1 Like

Yes, it is.

I agree we should do this, the only issue for me is this will not fix the same problem with migrations.

I think there is something about the “good” hosting that is not quite as good as expected, possibly one or more of the things I mentioned above, for example disk access speed combined with a hard execution limit enforced by the host.

Anyway the best thing we can do about this right now is collect information. If this is happening on any hosting providers other than Zuver and Synergy then please do let us know.

This is a good clue! As Tim said above, LiteSpeed may not be the cause of the issue itself (but still might be because it’s an intermittent issue). Or, if these providers do in fact share the same server configuration, it could be something about that.

Edit to add: yes, I was able to confirm that Zuver and Synergy are both part of VentraIP (ref1, ref2, ref3). To me this points strongly towards a server configuration issue that is common to these providers.

True. However, we’ve either inherited a bug or misfeature from WP, or (more likely) it’s a hosting issue we’ll have to go to great lengths to work around; without being able to reproduce it on demand the odds of fixing it except by accident are pretty remote.

It’s not that I think we shouldn’t try to fix it, just that we should be completely sure what it is we’re trying to fix before diving into rewriting the whole install/update system.


Yes, I still think that is the most likely. They run a very tight ship and I have been up against restrictions in the past caused by some of their over-zealous lockdown settings. Still, the settings should be the same across all servers so odd that only a few sites are triggered.

I was assuming that anyway, until @spanner44 also reported exactly the same issue. He is in France so I doubt he’s a Synergy customer.

Agree with this. I think we should just monitor the situation at this stage.


Not the same issue, what he described would be a failed download from GitHub which would happen any time the server has a network issue or just an intermittent failed connection, and then the upgrade should succeed when it is resolved. The upgrade process is designed to cope with this more common type of failure. Instead it seems like you are experiencing failures basically randomly throughout all parts of the upgrade process, and some of these are pretty bad like when a file is only partially written.

This kind of problem is sort of like “my car won’t start” for a mechanic, there are many different possible causes that all show similar symptoms.

1 Like

I had the same trouble about two years ago with WP, but I wasn’t able to understand what was wrong.

Edit: on Aruba VPS, Italy.

I run a VPS on Smart Hosting / Krystal and have migrated 6 sites, 2 of which I did while running Litespeed. I’m now back on Apache but haven’t run into any problems with any migration. I’ve also migrated a few sites on my local WAMP PC and again, no problem.

The one and only time I’ve had problems upgrading a WordPress site (not quite the same as migrating from WordPress to ClassicPress - but similar), it was on cheap hosting. When I contacted them, they said there were two issues: a) file permission problems and b) problems caused by custom modsec rules. They obviously wouldn’t go into details on the latter.

But is it possible that custom modsec rules could be detecting CP as a rogue WP installation?

This is entirely possible. I have had problems in the past with their modsec rules giving me 403 pages for entirely innocuous reasons (on non-WP sites). I wonder if their rules are customised around WP?

1 Like

Just to clarify what happened to me, which from the sounds of the things in this thread, isn’t the same problem I had.

When I clicked the update button, it said it was downloading it and then got stuck on unpacking. The site didn’t go into maintenance mode as I was still able to access the site and also the dashboard in another tab. In the fresh tab with the dashboard, it still said the update was available, but when I clicked it again, it said an update process had started, and if it failed try again in 15 minutes.

Which is what I did and the site updated properly.

I am on shared hosting ( and suspect that when I did the update, I lost connection with the server, as I was doing this around midnight (French Time) and this is always the time when I lose connections with the server, which I put down to them doing maintenance or something as it only last a minute or so.

Sorry, I didn’t check the logs, as when the update went through and completed, I didn’t think anything of it until I saw this thread.


Something like this would cause a specific, repeatable failure rather than what we have been looking at in this thread.

Modsec rules are set on a “per-server” basis aren’t they? And I know they tweak them for individual cases.

I had a Perch site that was continually giving 403 pages whenever the client tried to add a description. We must have had to whitelist a dozen different little things to let them add their text. It was getting tedious after a while. At one point I was told it was being triggered by a semi-colon followed by a space, because Mod Security detected that this may be an SQL injection attempt. Now, I know I can put a semi-colon space into a WP page and it doesn’t give me a 403.

But, yes, it doesn’t explain why it happens at different stages, and even sometimes works.

@mathewcallaghan - I contacted senior management at Synergy to ask if they had any more ideas about this. As you probably know, they are very proactive at sorting out problems and are always looking to improve their services. They did some testing on one site I still had on 1.0.1 (I’d tried to upgrade it once and it stalled mid-download).

This is their response:

I’ve tried this a couple of times and rolled it back via a restore point I’d set up but has gone through successfully each time. It’s possible some recent updates/changes have resolved the issue that was present (As we’ve had cPanel, Litespeed and Cloudlinux patches in the last week). I’ve also combed through a couple of the sites I’ve found CP running on and not been able to determine much from the logs it has recorded.

If you do come across a site showing the issue please escalate it immediately and I’ll take another look and see what we can find. You can make use of an urgent bump to bring it to our attention immediately and I’ll cancel off the invoice it creates.

So, for now there is not much else we can do. It will be interesting to see what happens in the next upgrade in a few weeks time.


This is continuing to be an issue. I have updates that crash mid-stream, leaving me in maintenance mode and sometimes with corrupted files requiring a backup to be restored. I had previously set up duplicate sites on another host (Micron21) and these update perfectly, so it must be something to do with the server setup on Synergy.

So I have to do manual uploads of new version for now, which is a pain. I’m considering other hosting options. Unfortunately Micron21 is noticeably slower so I won’t be using them.

1 Like

I had few sites automatically update today without issue on synergy hosting. I am not praising them at all but letting you know.