SMTP client error

When testing, it throws out an error like the one in the picture.
What’s the problem

Are you trying to use an SMTP plugin in ClassicPress? In that case, using Gmail to send email from your website won’t work, because that only works in email clients.

You will need to use your own custom domain for your emails, and you will need to register/subscribe to an SMTP service provider. Usually, mailing list services, like MailChimp, also offer SMTP.

I’ve never tried SMTP with Gmail, but you might need to enable less secure apps for it to work.

Less secure applications are enabled “thunderbird” works properly.
Until recently it worked properly via gmail (I don’t know exactly since because I didn’t pay attention) and the SMTP client worked properly and then I accidentally went to check and see that something is wrong

Try using port 587.

Although for email SSL and TLS are pretty much identical and should be considered interchangeable sometimes they are not treated as such.

Gmail seems to accept SSL connections go port 465 and TLS on 587.

I also tried this option but it doesn’t help

I just tested this myself from a localhost setup using my Gmail address, the email was rejected but I also instantly got notification from GMail as follows:

Someone just used your password to try to sign in to your account from a non-Google app. Google blocked them, but you should check what happened. Review your account activity to make sure that no one else has access.

Following the link in the email I confirmed it was me and I was advised that a “Less secure app blocked” event had happened.

So there are plugins that work and will work with changed Gmail security settings. I was using:

I’m familiar with gmail’s security notice from before

Someone just used your password to try to sign …

And I installed this plug-in of your SMTP mailer (but it is not safe for ClassicPress) and there is no error notification on it for testing, but I do not receive any message or security notification from gmail on gmail
I also looked among the spam messages
Without an SMTP client, my contact forms don’t work.
But I found an alternative to plugin contact forms in google forms which for now seem to work without SMTP client

The plugin is declaring it requires WordPress 5.9 and above but it worked just fine when I tested it - plugin and theme authors often don’t have the time to test so just support the current version.

I’m glad you got things working. It might be worth checking that your hosting provider allow out-going connections to SMTP servers and on those ports, the issue may not be remote but local on your server. Not a priority for now though if you have it working.

I also tried the SMTP mailer on localhost but the same thing has no inbox or security warning from google

I use the google form for contact here

But now I have another problem without the SMTP client functioning.
User registration
Users and I do not receive a return email notification of successful registration, etc.

After reading this, usign SMTP Gmail will work, you need to change your password if you have 2 step authenication enabled. in the gmail account management section, u need to generate an one time pasword… u can’t use your oriiginal password for the account.

Sorry I was away for a while.
I took your advice and tried to configure it to generate a one-time password but it was all in vain
I also tried to configure an SMTP client via Zoho mail, more SMTP clients, but all in vain.
I did all these actions on a local XAMPP server

Please can you use the following plugin, configure it and try sending a test email, it will dump to screen a lot of data that will help us narrow what your issue is:

A connection error could be an issue reaching the server, son DNS error on our hosting server, it could be a user name or password issue.

It should look like this:

2022-02-20 10:21:54 Connection: opening to, timeout=300, options=array()
2022-02-20 10:21:54 Connection: opened
2022-02-20 10:21:54 SMTP INBOUND: "220 ESMTP w8sm46952828wre.83 - gsmtp"
2022-02-20 10:21:54 SERVER -> CLIENT: 220 ESMTP w8sm46952828wre.83 - gsmtp
2022-02-20 10:21:54 CLIENT -> SERVER: EHLO localhost
2022-02-20 10:21:54 SMTP INBOUND: " at your service, []"
2022-02-20 10:21:54 SMTP INBOUND: "250-SIZE 35882577"
2022-02-20 10:21:54 SMTP INBOUND: "250-8BITMIME"
2022-02-20 10:21:54 SMTP INBOUND: "250-STARTTLS"
2022-02-20 10:21:54 SMTP INBOUND: "250-PIPELINING"
2022-02-20 10:21:54 SMTP INBOUND: "250-CHUNKING"
2022-02-20 10:21:54 SMTP INBOUND: "250 SMTPUTF8"

Whatever I do doesn’t help.
After configuring the SMTP mailer and generating a temporary password and sending a test message it doesn’t throw me any error or that it was sent successfully.
Figure 1

Figure 2

I just don’t understand what it means to configure the wp_mail () function to use SMTP instead of the PHP mail () function.
Where this is configured on lockalhost (XAMPP) or in the SMTP Mailer client
I’m not a programmer

Link to how to configure send mail on xampp
php - How to configure XAMPP to send mail from localhost? - Stack Overflow.

Okay, PHP is a language that has a whole variety of functions that perform tasks for you, at the most simple level perhaps you have:

echo 'Hello World!";

That simply outputs “Hello World!” to the browser for example.

PHP also contains the mail() function. It sends an email to an address with Subject line and message content BUT it sends that message though the web server via a binary application for the purpose - usually that is sendmail - that process is not authenticated and is heavily controlled by hosting providers as it can easily be missed to spam people.

SMTP are email servers for the purpose of sending emails, you almost always have to authenticate with a username and password to be able to sent via these, it means the process is more likely to work as it is less open to spamming.

In Figure 2 above, try to send a test email - enter an email address you own, a subject and message and click “Send Email” - then read the message on screen and maybe post the here so we can tell you why it isn’t working.

I did everything as it says in the link above, I configured both php.ini and sendmail.ini
Entered data SMTP mailer as it goes generated password
Sent a test message to another email, but all in vain.
in Figure 2, empty fields remained after the test message was sent
Thanks for trying to help but I give up and give up on this.
If I manage to configure XAMPP, how will I configure the hosting server on which my website is located
An account without an innkeeper