Strange behaviour of site going transparent

Okay. Hopefully this is it

openssl

OpenSSL support enabled
OpenSSL Library Version OpenSSL 1.1.1p 21 Jun 2022
OpenSSL Header Version OpenSSL 1.1.1p 21 Jun 2022
Openssl default config /opt/alt/openssl11/etc/pki/tls/openssl.cnf

Can you find out from your host if they can upgrade your OpenSSL to something above v3?

So I have been doing some test, so I downgraded to 1.1.1p and i got the same error.

Warning: file_get_contents(): SSL operation failed with code 1. OpenSSL Error messages: error:16000069:STORE routines::unregistered scheme error:80000002:system library::No such file or directory error:16000069:STORE routines::unregistered scheme error:80000002:system library::No such file or directory error:16000069:STORE routines::unregistered scheme error:80000002:system library::No such file or directory error:0A000086:SSL routines::certificate verify failed in /srv/www/luthemes/public_html/wp-content/plugins/classicpress-seo/includes/admin/class-admin-helper.php on line 44
Warning: file_get_contents(): Failed to enable crypto in /srv/www/luthemes/public_html/wp-content/plugins/classicpress-seo/includes/admin/class-admin-helper.php on line 44
Warning: file_get_contents(https://luthemes.com/wp-content/plugins/classicpress-seo//assets/admin/img/classic-seo-dashicon-white-on-transparent.svg): failed to open stream: operation failed in /srv/www/luthemes/public_html/wp-content/plugins/classicpress-seo/includes/admin/class-admin-helper.php on line 44

so this just tells me that version 1.1.1p has issues.

I am currently testing 1.1.1t which I believe is the latest version and seems to be the same. this issue didn’t start from the release of 1.1.1e

@spanner44 are you able to find a way to downgrade to 1.1.1 without the letter or upgrade to the latest.

I think v3 is for php8?
spanner44 is running 7.4
Debian 11 is using ‘n’ with 7.4.33

If I’m not mistaken, @benlumia007 was testing PHP 7.4 with OpenSSL 3.x. But he was using Docker.

We’re running OpenSSL 1.1.1 (no letter) on our Litespeed server. It has no issues. I believe this issue was introduced in 1.1.1e. So reverting to 1.1.1, if possible, would be the best option.

Any plugins/themes using file_get_contents() should throw the same error while trying to get a file proxied by Cloudflare.

OK
I probably put too much weight into how Debian APT offers version upgrades.
:zipper_mouth_face:

I was testing CP 1.5.3 and PHP 7.4.

Maybe try turning off the proxied and see if that resolves the issue.

Family emergency, so haven’t been able to do much, will persevere later today. Something I have noticed though from the limited time I have had, is that when the Debug plugin is activated that @EliteStarServices recommended, the problem doesn’t occur, and the Classicpress SEO works without a problem. When I deactivate the Debug Plugin, the problem returns.

Don’t know if that sheds any light on the problem, or just causes more confusion

So, just to update, I have contacted support to see if they can change the OpenSSL. I await an answer.

So far this what the testing I have done, and the results.

  1. ClassicpressSEO with no Cloudflare - Works but impossible to set up SSL
  2. ClassicpressSEO + Cloudflare - Get the transparent screen thingy, so does not work.
  3. ClassicpressSEO+Debug plugin activated +Cloudflare - Works okay with SSL from cloudflare working.

So for the moment, I can use the site using option 3. I don’t know why this option works. Obviously if the hosting change the OpenSSL, then this will hopefully resolve all the problems.

What concerns me though is if this happens to anyone else, although I presume that this seems quite an exclusive problem to me.

The link in the original post contains a space in the plugin folder name. Was that just a typo or is that space really there?
The error messages indicate an extra slash there:
https://chb44.com/wp-content/plugins/classicpress-seo//assets/admin/img/classic-seo-dashicon-white-on-transparent.svg

This is the address that is in the browser, copied and then pasted here:

https://chb44.com/wp-content/plugins/classicpress-seo%20/assets/admin/img/classic-seo-dashicon-white-on-transparent.svg

So, just heard back from the hosting, and they cannot change the Open SSL, so I have decided to go back to not having cloudflare for now, so no SSL, and hopefully a solution will surface in the future

What problems are you having with a regular SSL certificate? If your host offers Let’s Encrypt, they should be able to help you set it up.

It started a while ago. The site was inactive for a while and when I came back I encountered the problem. I initially thought the problem was with Cklassicpress SEO as this where the error message were, and when I deactivated it, the site worked. So I just resorted to having no SSL.

When I encountered this, I initially tried to add an SSl with a plugin, but that would not work so I reached out on here and a member on here Dernard, I think, tried to solve the problem, both manually and with a plugin, but it seems that he couldn’t solve the issue.

Moving forward a few months, I read that cloudflare includes the SSl so thought I would set that up, and hence I have encountered these problems.

At the moment, I have contacted the hosting once more to see if support could help me with the set up of the certificate, and I am awaiting a response. So my site is just now HTTP without cloudflare running, and the site works okay, although on the dashboard and every admin page it lists a load of errors:

Warning : file_get_contents(): SSL operation failed with code 1. OpenSSL Error messages: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed in /home/xxx/public_html/wp-content/plugins/classicpress-seo /includes/admin/class-admin-helper.php on line 44

Warning : file_get_contents(): Failed to enable crypto in /home/xxx/public_html/wp-content/plugins/classicpress-seo /includes/admin/class-admin-helper.php on line 44

Warning : file_get_contents(https://chb44.com/wp-content/plugins/classicpress-seo //assets/admin/img/classic-seo-dashicon-white-on-transparent.svg): failed to open stream: operation failed in /home/xxx/public_html/wp-content/plugins/classicpress-seo /includes/admin/class-admin-helper.php on line 44

Warning: file_get_contents(): SSL operation failed with code 1. OpenSSL Error messages: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed in /home/xxx/public_html/wp-content/plugins/classicpress-seo /includes/admin/class-admin-helper.php on line 44

Warning: file_get_contents(): Failed to enable crypto in /home/xxx/public_html/wp-content/plugins/classicpress-seo /includes/admin/class-admin-helper.php on line 44

Warning: file_get_contents(https://chb44.com/wp-content/plugins/classicpress-seo //assets/admin/img/classic-seo-dashicon-white-on-transparent.svg): failed to open stream: operation failed in /home/xxx/public_html/wp-content/plugins/classicpress-seo /includes/admin/class-admin-helper.php on line 44

But the site works and I can make posts.

I did all the usual things like deactivating all the plugins etc, but nothing seems to make it better, it just seems to get worse so if anyone has any ideas, then I would appreciate it, but I am hoping that perhaps it might correct itself with V2.

We got an update for the ClassicPress SEO plugin (thanks to @Simone) and rewrote the function causing problems with Cloudflare/OpenSSL.

Can you test the new version with Cloudflare SSL enabled? The issue should be gone, hopefully.

You can download the new beta version here:
https://github.com/ClassicPress/classicpress-seo/releases/download/v1.2.3-beta/classicpress-seo.zip

Simply upload this file as a regular plugin. CP will ask you to update to the new version. I would recommend doing this before enabling Cloudflare SSL.

2 Likes

I have tested and seems to activate properly.

1 Like

So, I have installed it, and I am waiting for things to redirect, but so far, no error messages, so fingers crossed it will be okay. When I uploaded it, it didn’t update the other Classicpressseo, so I have the newer version activated and the older one deactivated. Is it safe to delete the old one, and if so, via the plugins list or via the Cpanel?

Many thanks to all of you here for you time and effort that you have taken to resolve this for me. Unfortunately, my technical skills are not that good, so I rely on a good team to provide support as you all have done.

3 Likes

you can delete the old one via dashboard or via the CPanel, I would strongly advise to do that via dashboard however since it fires a function that cleans up after it while deleting.

Feel free to ask every question you might have, and do ask help when needed. The community is what makes ClassicPress special, unlike other communities, everyone here is happy to help people succeed in using CP.

1 Like

ClassicPress SEO by default do not clean it’s options and table.
So the old one can be safely deleted without loosing your configuration.

For reference, there is a hook to tell ClassicPress SEO to delete all the data at uninstall:
add_filter( 'cpseo_clear_data_on_uninstall', '__return_true' );

2 Likes