The automatic upgrade to CP 1.0.1 crashed my page

After the automatic upgrade I had error 500
After manual upgrading, FilleZilla page is back to work again
How to prevent automatic upgrades

No issue at all for me, but the question asked is an interesting one: it would be good to know how to prevent automatic upgrades if need there is - and preferably to have an option for that in one’s control panel (obviously with all usual warnings: do it only if you know what you are doing, not recommended, etc…).

BTW, that is interesting: I had assumed that all my three site already on CP (just added a fourth one) had updated automatically to v 1.0.1, but I realize that only one did (they are all with the same host). I have now updated the other two manually, with no issue.

Now i see it does not even go upgrades in the admin panel CP.
It comes to the preparation of the latest version of the installation and is so long standing
The only thing that passes the upgrade manually through the filezilla

OK, the fact that one site updated automatically and the other two don’t is probably related to my settings on iControl WP management panel - I had not remembered that such features could be activated in that panel.


The auto-updated was only a security fix so it shouldn’t have impacted anything: ClassicPress 1.0.1 Release Notes

Do you have error logs or screenshots you can share so we can understand what is going on?

1 Like

Problems with automatic upgrades are very rare, but not impossible. As Wade says, it would be nice to see an error message from the PHP error log.

Here is the documentation for automatic upgrades, including how to disable them:

I have noticed that my sites, even with the same host, upgrade at different times.

Also I read this somewhere…

You can modify the behavior of automatic upgrades setting using the same method as in WordPress (by defining the WP_AUTO_UPDATE_CORE constant in your config file, or by installing plugins that modify this functionality).

1 Like

I cover stopping automatic updates for WordPress in this post:
The same will apply to ClassicPress.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.