The site icon site identity does not work

When editing the page identity
Site Logo loads properly
But the Site Icon, i.e. that small icon, does not load

The site icon site identity does not work
The problem is the same in ClassicPress 1.7.3 and 2.0

Can you provide more details?

Maybe installing Query Monitor you can get even more info.

Site icon are working on every site on my servers, v1.7 and 2.0.

Setting the favicon is the same on both 1.7 and 2.0
watch the video on the link

Like @Simone, it’s working perfectly for me. So you probably have a plugin or theme conflict.

On a test site, try deactivating all your plugins and see if it works then. If it does, then reactivate them one by one to find the culprit. To test if it’s your theme, try switching to a default them and see if it works then. If it does, it’s your theme that’s the culprit.

I changed the themes and before your suggestion the effect is the same. At your suggestion, I deactivate all plugins. Even without activating the plugins, there is no change. Only when I activated the WP plugin All in favicon did the site icon appear

Did you start using ‘All In Favicon’ to address your favicon issue, or were you using the plugin already?
Just wondering, because as with Simone and Tim, I have multiple sites and none have this problem.
What browser are you using?
Have you checked if the issue is the same in a different browser?

The problem is solved.
The problem is in XAMPP the latest version and PHP 8.0
How did I get there?
On the server where my site is, I created a test subdomain and transferred the site to that subdomain.
And on that subdomain, I had no problem with adding the site icon.
PHP version 7.4 is on my server (Namecheap)
It means that ClassicPress is not yet ready for PHP version 8.0

Happy to know that you have solved your problem.

But I don’t have this issue with PHP 8 in both CP 1.7.3 and 2.0.0. No issues even in two production sites with PHP 8.3 and CP 2.

So please install Query Monitor and look at the browser’s console so we can understand more about this.

1 Like

Glad to hear some progress is being made.
I can also confirm that the problem is not PHP 8+, my sites are running PHP 8+ without trouble.

I suspect XAMPP could be at least part of the issue, are you self hosting?
You mentioned namecheap, but generally speaking, XAMPP is used for local testing or self hosting.

1 Like

I deleted the latest version of XAMPP and installed an older version with PHP 7.4 and now the site icon works fine on both CP v1 and CP v2

EDIT: I installed Query Monitor but never used it so I don’t know how it works

I don’t know if I should open a new topic or write here, but I encountered a new problem
When importing posts using WordPress Importer version 0.8.2. taken from here

After entering the posts, the posts are visible as web pages.
But when I go into the post editor some posts look somewhat normal because in every post strange tags appear at the beginning and end of the post () which in there is no original post
But there are quite a few posts that are empty in the editor, there is nothing either visually or as html text
I encountered this problem earlier, and evio is now repeating itself
Honestly, I’m getting a little tired of ClassicPress, because every now and then some new problems appear

Since software and systems are constantly evolving, nothing is ever going to be 100% trouble free over the long term. Some upgrades will be more painful than others, but it is part of running a website.

Simone may be able to help with using Query Monitor, and I think there might have been something with the importer that has been patched now, but may not be in v2.0.0, sorry that I do not have the definitive answer on that right now.

One thing I will say is that the team here is willing to help with any problems and make sure bugs are addressed when found.

Query monitor just adds a menu that helps you to debug.

Screenshots for a fatal error and for wp_remote_get('');.

About the importer, in v2.1 you can install it directly as the others, just this.

After a long time I decide to get my site in order from scratch in XAMPP localhost before uploading to the server.
Over the years, all kinds of things have been collected on the site, the database has grown quite a bit.
I exported the posts. And I didn’t export the posts all at once, I divided the larger ones into several segments during export.
and then when I go to import them one by one using the importer, it doesn’t do its job properly.
Now I have to review over 800 posts each separately to see what was uploaded and what wasn’t.
And what will happen tomorrow when there are 5000 posts and pages on the website, I can’t even think

And I don’t want to go to CP v 2+ yet, I’ll stay on v1 and PHP 7.4 until further notice, because 2+ still has problems

The importer was removed from CP v1 because it did not work.
Instruction were added to explain to use importer v.0.7.
Importer will be back in CP 2.1 because the latest version is compatible with CP v2.

Just can’t understand what you mean about problems in v2.

There are also several ways to move data from one site to another.
This includes plugins that export / import your actual database (which can also be done manually).
I am not saying the import tool is the wrong way to go about cloning a site, only that I would lean toward some of the tools designed to move a site from one server to another.

Also, if you are having better luck with v1.7.3 and php 7, you can keep using that while you create a clean clone of your existing site and work out any problems.

Our point is while there will be issues and edge cases with individual configurations, claiming that your problems are due to ClassicPress v2 ‘not being ready’ is not an accurate representation of the situation.

1 Like

Now I got down to business and I have to go through every post (more than 800) and check which ones have been properly transferred and which ones haven’t.
Here’s another reason why I won’t switch to v2 yet is that the importer doesn’t work properly.
After launching CP v2, several plugins I’ve been using for years stopped working or had a fatal error.
I don’t want to investigate what other problems CP v2 might have in the future.

I know there are multiple ways to clone a site.
But as all sorts of things have accumulated in the database over the years by adding and deleting various plugins and themes, I wanted to do it from the beginning in the local server
And then the transfer of posts was the easiest export and import for me, and now due to problems with import I have to go through each post and page separately

Here’s the thing, though. The importer is the same one that WP uses, and posts work the same way on both. So the problem you’ve had with importing posts into your CP site would also have arisen on your site if you’d been using WP.

In other words, there’s something specific to your site that’s causing this problem, and whether you stay with CP or move to WP, you will continue to experience such issues until you identify the cause and fix it.

1 Like

Maybe then the problem is not the importer but the exporter.
Something not good happens between those two plots.
After the import and when opening the post, I have everything empty both in the visual and in the html editor. Only when I reload the page in the html editor does the text and tags appear as in picture 2 and 3
This is what the post looks like before the import-export operation
Picture 1
Bez problema 1

And this is what the same announcement looks like after import
In the html editor, the tag <![CDATA[] appears at the beginning, which is not in the original post and which I did not add
Figure 2
Problem 2

At the end of that post, you get this ]]> tag, which is also not in the original post
Figure 3
Problem 3

And so every post

This was all done in CP 1.7.3 and PHP 7.4
The original post is on the server where my site is hosted, and the import host is XAMPP localhost and importer 7.0 is used