Theme update failed: nightly.20230707

I am not sure when this was introduced, but using the latest version (nightly.20230707) I am getting the following error when I try to update a theme:

However, the theme ZIP file is correctly configured, I also verified it works fine in WP, CP v1.53 and on a CPv2 site still running version: 2.0.0+nightly.20230615. So it seems the problem was introduced between then and version: 2.0.0+nightly.20230707.

Just a quick addition to this.
The theme installs fine, the error occurs on update. ← Not sure this is relevant, see below.

In another possible twist, a site that was installed as CPv2 seems to update OK even using the latest nightly - the error is on a WP site that used the migration plugin to convert to CPv1, then was updated to CPv2 via file copy. That said, I am going to see what happens on a few more sites to try and isolate what is actually causing this to happen. Debug mode is not popping any errors during the process.

OK, I tried updates using 2017 and that works fine, so now I have to assume something on my end or with my theme is triggering this. Odd that it is only this one CP site acting up, but I use PUC and TGM so need to do more poking around before I call this a CP bug at this point.

Am I going in a circle?

I have a question:
Does a core upgrade replace all files, if so, I am slightly confused.

The 3rd Party Utility TGM (TGM Plugin Activation) is causing the update failure, and I think it is bringing out a bug in CP. Here is what I think is happening based on my tests:

TGM includes a folder called plugins, in this folder is a zip file for a sample plugin as part of an example on how to package plugins. That is the file being found and causing the zip file structure error, it is nested into the theme’s /inc folder but is somehow being mistaken as the theme zip?

Removing that zip file created a new error though, this time saying no file named style.css was found.

In that same nested /inc folder is the TGM application - it is called tgm-plugin. Again, somehow, I suspect because the word ‘plugin’ is included in the folder name, that folder is being found and considered the upgrade folder.

Removing the tgm-plugin folder, which includes that zip file nested under another folder named plugins cures the issue, but of course is not the solution since nothing is wrong with TGM, is has worked great for years, so I think something in CP is looking at the file structure incorrectly.

Tagging @MattyRob @Simone

I have upgraded the theme on nearly all my sites now and the error / failure has only occurred on that one site, so I would log this as more of something to watch for?

Since I am unable to replicate the problem on another site or define the specific reason for it, expending energy chasing a possible ghost is probably not the best use of time.

I set up a ClassicPress site at WPSandbox, migrated to the v2 nightly and installed the time. I edited the theme file to a lower version, the update showed and applied so seems maybe a single site issue. Maybe symlinks on the server or some sort of circular folder configuration.

Thanks for taking a peek.
I was never able to to duplicate it on another site either.
I also removed all plugins and themes (except 2017), no change.
Reverted back to WP, no change.

It is driving me crazy, but would seem to be something specific to that server - very odd, it is a clone like most of my Debian servers and a very simple testing site. The site and server also otherwise behave fine and I am not seeing any errors or anything to guide me to the issue, so I am a bit frustrated with it.

I can just upload the files directly, so it is more of a ‘WTF is going on’ that I want to figure out.
Just knowing that the TGM utility is causing the issue got me no closer either, since that program is not ‘the problem’, I have over a dozen other sites that use the theme with TGM and upgraded with no issue.

Same here, update went smoothly on a live site.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.