Unable to Switch to ClassicPress

resolved

#1

Hi, guys. I have a weird issue. I haven’t switched a site over to CP in a few days / week or two so I may have forgotten a step somewhere.

I have a site that is not WP 5.0 yet. I have Disable All WordPress Updates running and active. WordFence active. Really Simple SSL installed as well. I tried to switch over to CP and got all green flags but when I switched over, nothing happened. I got an alert about updating my Really Simple SSL settings. Did that and still nothing happened.

When I checked, it was still showing WordPress as the CMS with no other noticeable changes.

I have 2 backups of the site on UpdraftPlus.

Should I disable Disable All WordPress Updates, let it update security patches, and disable WordFence and then try again?


Updating Question
#2

You’ll need to disable this, because the migration plugin uses the WP upgrade system internally.

This plugin is already listed in our documentation as conflicting with the migration process: https://docs.classicpress.net/installing-classicpress/#plugin-conflicts


Updating Question
#3

Is this why it went to the SSL screen and just stopped there?

I was afraid to deactivate Disable All WordPress Updates because I am assuming it will start updating to 4.9.9 right away for the security “minor” patches. Is that okay to do and then try the CP switch?


#4

I am not sure what the “SSL screen” is, but most likely, yes.

Same as I replied on the other thread, yes this is fine.


#5

Thanks. Sorry for the repeat. I was not sure where the best place to post was and even though this is a small, low traffic site, the client freaks out if it’s down for even a few minutes.

Everything seems to be okay now. I turned off the Disable All WordPress Updates and WordFence. Made the switch to CP okay. Then went back into WordFence to reactivate it and change the settings a little.


#6

No worries! Glad everything worked out, we’ll be here if you need anything else.


#7

James…spoke too soon I think.

I just updated and checked all the pages. One thing I noticed that is odd is that if you go to https://RubyMoonInvestigations.com (the client site) and click on “About” on Firefox, the footer area is humongous. I don’t recall seeing this before.

What can I do? I’m posting this on the Divi forums as well but it seems a weird spacing glitch in the matrix.

Not really a Earth-shattering problem as it seems to adjust depending depending on browser screen size but just noticed it. Probably more of a Divi issue than a CP one…


#8

The issue below the footer seems to be related to the content height of the about page because it has less content than the other pages, and definitely related to the theme or any custom CSS that may exist.

I can also see that in other pages so it’s a global thing in the CSS of the main content of the theme.
CloudApp


#9

It looks like what you’re describing will only happen on larger screens, for pages with small content that doesn’t take up a full screen:

I don’t think this is a ClassicPress issue – my theory is that you haven’t looked at this site before using this large of a screen size (or you don’t remember seeing it because it’s not going to be a very common issue).


#10

Thanks for everyone responding. I wigged out at first (Rockstar on an empty stomach doesn’t play well with nerves and anxious clients). Then I realized what you guys said and can add more introductory text to fix it, or tinker with the CSS and backgrounds. Some guys on the Divi Facebook groups also gave me several other options. So…sorry for the post…please delete whenever you want.


#11

You don’t have to apologize for posting here.

Sometimes when you make a change, you take a closer look at the site after you make the change. This means you find new issues, even if sometimes they were already there before.

So, thanks for paying attention. We’re committed to finding and fixing issues with ClassicPress when they come up.


#12

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.