Unable to update SEO - blocked

Hi, I have a question about this odd occurance. I have a site running CP, Divi, and a handful of plugins, including All In One SEO Pack. While checking WordFence, and then trying to tweak the client’s SEO, I was blocked by this odd alert. Can anyone help with what this means or what could be causing it? I thought it was very odd that I could not change SEO settings.

This is the alert I got:

Not Acceptable!
An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.

It’s possible that the mod_security PHP module (on the server) flagged some sort of activity as suspicious and is therefore blocking further activity from that same user. For example, while designing custom login screens, I had to repeatedly type wrong passwords, which mod_security flagged as suspicious and locked me from doing any more attempts. This block (usually) goes away after 10-15 minutes… or you can optionally disable what is often called “Extra Web Security” for the domain to get back in immediately; the setting (for me) is in my hosting control panel, but, it may also be an option in your security plugin.

3 Likes

Thanks. I’m on the phone with the hosting company now, but they recently updated to PHP 7.3 without notifying me, and some of the other PHP settings aren’t what they should so…I have a feeling the bug is in there somewhere.

I ran into this problem recently on a WP 4.9.x site running on PHP7.2. Never got to the bottom of why it happened but it turned out to be an issue with Wordfence rather than mod_security. Wordfence had blocked the user’s IP. Had to clear the IP from the database and all was well after that.

Have you tried disabling Wordfence (via FTP if necessary)?