Wann kommt die erste stabile Version?

resolved

#1

Hallo im neuen Jahr!

Wie berichtet, geht der Customizer nur, wenn man das Ding auf englisch einstellt. KA. ob das noch jemanden auffiel, bei mir ists halt so.

So kann man nicht arbeiten, denn wegen jeder Kleinigkeit ploppt ja der Customizer auf.
Ok, ich mache das Feintunig eh lieber per CSS im Child-Theme, aber selbst das einstellen des Header-Bildes ist bei vielen Themes eben nur per Customizer zu machen - oder?

Daher müssen völlig neuen Webprojekte weiter auf WP basieren, die Kunden drängelten va. in den Weihnachtsferien und wollen schnell was sehen. Dh. man muss mit dem ClassicEditor Plugin fahren. Auch besche… der spinnt ja auch und ist nicht ewig verfügbar.

Daher warte ich schon auf die stabile CP Version - wo hoffentlich echte deutsche Sprachdateien dabei sind. (Wo findet man die eigentlich? Könnte man die aus einer WP Installation raus und in CP einbauen?, Was ist diese “core_DE”? und warum hat die Sprache so einen Einfluss auf den Customizer?)


#2

Für die Lösung dieser Problematik gibt es inzwischen ein experimentelles Plugin, dass die altbekannten Übersetzungsdateien von WP installiert. I.d.R. fehlen nur einige wenige Übersetzungs-Strings, d.h. an ein paar Stellen scheint die Basissprache, also Englisch durch, sollte aber bei weitem nicht so einen Leidensdruck verursachen, wie “100% NUR Englisch” :slight_smile:

cu, w0lf.


#3

:sunglasses: cool. Dh. mit dem Plugin habe ich dann “Deutsch” als zur Auswahl verfügbare Sprache drin?

naja, das allein ist es ja nicht. Sondern das eben der Customizer nur Englisch will. Das stört mich.

Dachte halt, die Sprachdateien müssen ja irgendwo in den Tiefen von WP zu finden sein. Und dann einfach in CP kopieren. Aber wenn das Plugin die findet, soll mirs Recht sein.

Danke für den Tipp! Teste ich demnächst.


#4

Ok, hab mal bei meiner Bleeding Edge-Installation nachgeschaut - damit hatte ich ja auch schon die Umstellung auf core_de bzw. “Deutsch” erfolgreich durchgeführt.

Der Customizer ist hier zum größten Teil eingedeutscht, einzelne Beschreibungen sind noch auf Englisch.
Gehe pauschal davon aus, dass der Übersetzungsgrad sich je nach gerade aktivem Theme verändern dürfte. D.h. also, wenn ein Theme gar keine Sprachdateien mitliefert, aber stärker auf den Customizer zurückgreift, präsentiert sich die Oberfläche in großem Anteil auf Englisch.

cu, w0lf.


#5

Ich glaub wir haben ein Missverständnis - der Übersetzungsgrad ist mir eher wurst.

Das Problem ist, dass der Customizer überhaupt nicht startet, sobald man auf diesen komischen “core_DE” ist.
Da steht ewig das der Customizer geladen wird … tuts aber nicht.
Sobald man auf Englisch umstellt, startet der Customizer wie gewohnt.


#6

Das ist schon etwas merkwürdig … bei mir tut das einwandfrei. Allerdings ist das eine von WP migrierte Version, d.h. die eigentlichen Sprachdaten könnten schon vorhanden gewesen sein. Andererseits habe ich diese Installation vorher NIE auf Deutsch gestellt gehabt - dort lief vorher eine WP 5.0-nightly build.

cu, w0lf.


#7

Nachtrag:
Hab dieses Plugin installiert, doch das nützt auch nix.

Die Sprache “Deutsch” bleibt unter “Verfügbar”, wird aber nicht runtergeladen (oder wie auch immer das nachinstallieren funktioniert?)

Glaube, wenn man die Quelle der Sprachpakete wüsste, könnte man das einfach runterladen und ins (inzwischen gefundene Verz.) \wp-content\languages rein. Dann sollte die Sprache als „ installiert “ gezeigt werden. Dann auswählen -> fertig.

Was aber immer noch nicht bedeutet, das dann der Customizer endlich startet … Wer weiß, ob der nicht weiter auf Englisch beharrt …


#8

Ah, das hat sich jetzt ein bissl überschnitten

Dann waren sie sicher dabei!
Auch wenn nicht aktiviert, die Dateien wurden sicher bei der Installation von WP mit installiert, kugelten dann halt “nutzlos” herum.

Ich rede ja vom frischen CP Setup zip (idF. diese beta2). Da wo ja sich ja vor der Installation nach fast nix im wp-content befindet, schon gar keine Sprachdateien.

Edit:
Hab ja schon 2 Sites von WP zu CP migriert (manuelle Methode), auch da Null Problemo!


#9

Problem gelöst!

Eine URL in eurem Plugin, also in der use-wordpress-language-packs.php, Zeile 42 brachte mich zu den Sprachpaketen.

Nämlich
Zeile 42: $url = ‘https://api.wordpress.org/translations/core/1.0/’;
zeigt alle Sprachpakete -> dann zu "https://downloads.wordpress.org/translation/core/5.0.2/de_DE.zip und das dann in \wp-content\languages entpackt.
Sprache “Deutsch” war dann unter “Installiert”, umgeschaltet, Fertig!

Das Beste kommt noch:
Der Customizer springt nun endlich wieder an!


CP auf deutsch?
#10

Ok, ich werd das mal als Bug in Github hinterlegen. Da läuft was gewaltig schief - denn im Normalfall müsste der Customizer trotz fehlender Sprachdateien einfach problemlos weiterlaufen, nur halt auf Englisch.

cu, w0lf.


#11

Danke.

Nur gut möglich, dass dies nur mir passiert? Oder nur mit FF. Oder nur weil … KA.
Sollte mehr testen, mit anderen Browsern, anderen Server-Settigs, und was weiß ich.

Im neuesten FF und per XAMPP gings halt nicht. Gut möglich, dass es bei einem richtigen Hoster einwandfrei läuft? Hab nur dzt. nirgends einen Platz frei auf einem live zugänglichen Server.


#12

Ne, das passiert nicht nur dir. Ist auch schon als Issue für eine russische Neuinstallation gemeldet worden: https://github.com/ClassicPress/ClassicPress/issues/323

Und erst recht sollte es nicht mit XAMPP passieren - das hat ja sehr hohe Speicherlimits etc. als Ausgangswerte, damit sollten auch Klassiker wie “zu wenig Arbeitsspeicher für PHP, wenn die deutsche Sprachdatei geladen wird” jederzeit erschlagen werden.

Meine persönliche Vermutung lautet dahingehend, dass irgendwas JS-seitig knallt, da insb. der Theme Customizer ja sehr JS-lastig ist. Beispielsweise könnte es sein, dass anstatt der englischen Standardzeichenketten nur LEERE Zeichenketten an den JS-Part übermittelt werden, der dann aussetzt o.ä.

cu, w0lf.


#13

aha :open_mouth:

Was dem Customizer stört weiß ich auch nicht. Der könnte ja auch mit den “core-de_DE .mo .po” alleine laufen?

Aber bei mir zeigt die Konsole: (Sprache testweise wieder auf “core-de_DE” gestellt)

Nur: Warum werden die Sprachpakete beim wählen einer “verfügbaren” Sprachen nicht installiert? Lassen die von WP den Zugriff einer CP Installation auf downloads.wordpress … etwa nicht zu? Oder wie geht denn das nachladen von Sprachpaketen?

XAMPP: JA, denke jeder schraubt die Limits höher, auch Laufzeit usw. ich auch. Nur könnte ich als wenig versierter Webbastler ja sonst was verstellt haben.


#14

More information (English): https://github.com/ClassicPress/ClassicPress-Network/pull/29#issuecomment-452553941