Where's the shortcode to insert?

I know I did this before, but now I’m rebuilding the site after losing it to hackers. I’ve installed the Shortcodes Everywhere plugin. I want to insert a shortcode in a page. Where do I get the shortcode? I don’t see it appearing at the end of the widget information like I did in WP. I know I’m missing it somewhere. :face_with_spiral_eyes:

Shortcodes Anywhere plugin allows you to insert shortcodes in places where core doesn’t allow it out of the box. But I’m not sure if it actually creates it’s own shortcodes. I haven’t used it in a long time.

What type of shortcodes are you looking for? Or what are you trying to do?

Thanks for your reply.

I want to put Subscribe2 in the Display After Content plugin space.

subscribe2 is a widget I think, so you need to go to widgets page and look for the “after content” section and put the subscribe2 widget there, and it will show in the front-end the form that you need for subscribers if I am not mistaken.

You can also have a plugin (can’t remember the name) that gives you a shortcode for widgets (it creates shortcodes from each widget so you can use the shortcode to put them in places that are not “widgetized areas” like posts and pages.

The after content plugin creates a “sidebar” that gets published under the posts so if you place a widget of any kind there it shows it under the post.

You might be looking for [subscribe2] shortcode.

I’ll look for the plugin thanks.

Yes, I’ve used the after-content plugin before. Liked it so much I wanted to go with it again.

Thanks!

I was using initial caps for the word, so that’s why it didn’t work. Got it now, thanks!

BTW, how do I insert a horizontal line in the after-content plugin? The html code didn’t work. Gonna try three hyphens —

If HTML isn’t working, such as <hr>, one option is to add a border with CSS. If you can show us a sample page and explain where you want the line to appear, we can provide a snippet of CSS to add it.

Here’s a post; the after-content starts, at the moment, with the three dots:

http://cristaos.org/irmaos/vida-eterna-esboco/

Add the following CSS code under Appearance > Customize > Additional CSS:

.single .azc_dapc{
    border-top: 1px solid #dededc;
    padding-top: 20px;
}

The border color is the same as the little line in the bio. So it matches.

By the way, if you want to change “WordPress” to “ClassicPress” in the footer, I can help you do that :grinning:

That’s tremendous, thanks so much.

Funny, that footnote with the WP link doesn’t show up when I’m logged in. I had to pull up another browser, not logged in, and look to see it.

Please do send help to change that. Some themes have an option to change the footnote, but I didn’t see it in this one.

To do this, you need a child theme to prevent any changes to the code from being lost when the theme is updated. I’ve created a child theme, which includes code to change WordPress to ClassicPress inside functions.php file and also the CSS code for the border in style.css.

The child theme relies on the parent theme, so the Independent Publisher theme must remain on the website. When you upload and activate the child theme, check your settings in Appearance > Customize. Those may need to be changed again. Each theme has its own set of settings. The CSS you added before will be gone, but it’s already in the style.css. So no need to add it again.

cristaos.zip (80.1 KB)

Note, if you did modify anything in your theme’s functions.php file. You must move those to the new child theme’s functions.php.

Once child theme is activated, you should see this:
image

1 Like

Installed and proudly proclaiming CP. Thanks!

In the child theme the comments are not showing the authors. How to fix?

Can you please check under Appearance > Customize > General Options, if “Show Full Name in Comment Reply-to” checkbox is checked:

That took care of it! Thanks so much!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.