BulletProof Security Failed Update

resolved
#1

I now have 4 sites running ClassicPress and Bulletproof Security Pro on all of them.

Earlier today I tried updating the plugin as usual via standard WP/CP “Update Plugins” and got error as below

(Update Failed: The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature)

BPS Pro also has an internal facility to update from zip file within itself and this worked fine, so not critical, but it would be good to establish whether ClassicPress has a possible compatibility issue with standard plugin update method (and ways for plugin/theme authors to mitigate this if so).

Worth noting that the standard update method worked fine on all my WP sites, and to test I also tried reverting a CP site that failed to update to WP, at which point the BPS update installed with no issues, and then switching back to CP (working fine), so it isn’t an issue with my web host’s setup (the error above can apparently be caused by server site issues)

Alternatively/additionally perhaps BPS Pro is checking core files when doing an update. If this is the case, it would be useful to know from CP developers where the error above might be triggered before (I will also raise this issue direct with the developer of BPS Pro at same link on his forum as in my original post at
https://forum.ait-pro.com/forums/topic/bps-pro-compatibility-with-classicpress ).

Many thanks,

Rob

0 Likes

Bulletproof Security Pro and ClassicPress?
#2

@robf I have moved your comment to a new thread.

Does the update also fail on WP 4.9.x? Or is it only failing on ClassicPress?

Based on a quick Google search, possible reasons could include:

  1. There’s an issue with the zip file you’re uploading
  2. WordPress doesn’t have enough memory on the web server to unzip and upload the contents of the zip file
    (credit: smashballoon)

Do you have access to any server error logs that you could share?

0 Likes

#3

OK, I have edited the post to show link to BPS forum as referring to “1st post in thread” no longer makes sense when moved to new topic.

Thanks, but as in my post above, the update works fine on WP (so zip file and memory are fine) - the issue is just with CP, and only when updated via standard plugin method. BPSpro’s independent zip upload method within the plugin works fine.

I may be able to find the issue in error logs. If so is there a way I can send via private message?

Many thanks,

Rob

1 Like

#4

Is there anything in the logs here:

/wp-content/bps-backup/logs

2 Likes

#5

@robf, if you click on your icon in the top right there is a message icon, click that and you can create a new message.

Send the message to “Support” and then we can try to figure out what is going on.

1 Like

#6

Great, thanks @wadestriebel will do.

Thanks @gtman yes, lots of subfolders and files - much appreciated but will try direct message w/ support first

0 Likes

#7

I did a standard BPS update on a CP test site yesterday and it went through fine.

0 Likes

#8

Thanks @ozfiddler - is that using BPSfree or BPSpro? The problems I’m getting are with BPSpro which has a lot of extra features over the free version. All other plugin updates on CP so far work fine for me, this issue is just with BPSpro.

I had an update from the plugin author (see first post in this thread for link) and he is intending to test with CP

(quote) “I’ve been meaning to install a test ClassicPress site Locally for testing. So I will get to that either today or tomorrow. If I can reproduce the PclZip error then I can figure out the cause of the error. :wink: Ask the ClassicPress folks if they have modified PclZip in WP in any way.”

0 Likes

#9

Ah… right sorry. That was BPSfree.

0 Likes

#10

No problem. Useful to know free version is updating OK, and great that author is prepared to engage with ClassicPress.

2 Likes

#11

The issue with BPSpro update failing has now been diagnosed and resolved by @james on the site affected (very much appreciated, James!) and I have passed the info on to the BPSpro developer (see BPSpro forum link I gave in first post in this thread).

4 Likes

#12

BPSpro developer has acknowledged the issue and will be working on it soon: https://forum.ait-pro.com/forums/topic/bps-pro-compatibility-with-classicpress/

3 Likes

#13

Thanks for helping us get to the bottom of this Rob!

This issue is a very particular set of circumstances (pro plugin with custom updates + very strict server configuration). We’ll watch out for similar things in the future, but the best way to address them is still going to be for the plugin developer to fix the issue on their end.

3 Likes

#14

After seeing this issue a couple more times with different premium plugins and themes, we decided to implement a fix in ClassicPress.

Upgrade to 1.0.0-rc1 and you should have no further issues with BPS Pro updates.

3 Likes

#15

Many thanks, James, good to know. I’ve updated my CP sites (all 5 running fine with no issues) and have also updated the thread on BPSpro forums to let the developer know

2 Likes

#16

Marking this as resolved, please open a new thread if you see anything else. Thanks again for helping us get to the bottom of this issue, that was really what we needed in order to get it fixed on our end.

1 Like

closed #17

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

0 Likes