Unable to switch a site - question about possible cause

resolved

#1

A small site cannot switch to CP. Everything seems fine (see screenshot), but apparently the process does never really take place (if I abort the process after having waited for many minutes, everything works as it used to do before the attempted switch.

Unable to understand why: same plugins as on another site that I was able to switch easily on another hosting (I removed an additional plugin, juts in case, but it didn’t change anything). And on a test site with the same host, I was able to do a fresh install of CP without any problem.

However, I think that I might have a possible lead. By default, this hosting company disables some functions. See screenshot. Are there some that I should temporarily enable for the switch to take place?


#2

I have made a test by checking and activating all the options: it is not that. It has not worked. After waiting for 10 minutes (small sites, some 15 posts and 15 pages), the switch did not take place.

I attempted to upgrade to 4.9.9 first, just in case: didn’t solve the issue either.

Wondering what the issue can be. The hosting company is SwissCenter.


#3

@jfmayer: when you click that button, does a new page start loading in your browser, or does it just sit there doing nothing?

What browser and operating system are you using?


#4

No, it just sits there doing nothing. Only the button shows as if it had started doing something, but nothing else.
Yes, I thought that it might have been browser-related. I conducted attempts with Chrome, Safari and Firefox. I am on Mac OS Sierra, 10.12.6.


#5

Do you have a plugin active that disables WordPress updates, like Easy Updates Manager?


#6

No, I had it originally, but I removed it (not only deactivated it, removed it), and purged the cache several times after that.

But I you think that some remnant of it might remain somewhere, let me know, and I will check through FTP and remove that if it is still there.

Here is my list of plugins. I deactivated Sucuri for the switch, but it didn’t help.


#7

I would suggest deactivating Disable Gutenberg, WP Rocket and WPS Hide Login. I don’t use any of them, so I don’t know if it will make a difference, but they seem the most likely to be associated with this issue.


#8

OK, I will do that and come back to you with a report after that.


#9

No, unfortunately, it didn’t work (ny the way, I had those three plugins active on another site with another host, that I switched to ClassicPress without any trouble).

Wondering what the issue can be. Since I just migrated this site to the current hosting, ironically for the purpose of switching to CP once it would be done, I don’t want to go through another migration now.

But I have a WP test site with the same host. I will just attempt to switch it to CP, and see if it works. Otherwise, we will know that it has something to do with the hosting.


#10

OK, now it is sure: it has not to do with the site or plugins, but with the hosting. I have just tested the switch to CP on a test site in a subdomain, and nothing happened.
I have checked in the logs: nothing reported.
I attach three screenshots with the various configurations I have access to. Let me know if there is anything that I should change or activate temporarily for the switch to take place.
Thank you for your kind help!


#11

Is it possible for you to access the files via FTP or cPanel (or another admin panel the host uses)?

If yes, then that is an alternative way to switching to ClassicPress. You can read all the details and exact steps in our documentation: https://docs.classicpress.net/installing-classicpress/#migrating-to-classicpress-without-using-the-plugin


#12

Yes, I could try to do that via FTP (no cPanel with this hosting). Not tonight, because it is a little bit late, but tomorrow.

When I upload the entire install (except for wp-config-sample and the entire wp-content folder), do I need to specifiy permissions, or does that take place automatically?


#13

By the way, I see the mention not to do it in a production environment: the site IS in a production environment. But OK, if it means only a few minutes downtime, I could live with that.


#14

And still, it would be useful to understand what may cause the issue: not everybody will want to do that, and for CP to reach a wide audience, those are definitely issues that should be overcome.


#15

Usually when using FTP setting permissions is not necessary. Do you have to do so in other cases when using FTP?

Yes, that is correct. Usually beta versions of software are to be used in test environments, not in production. Of course you can also use it in production, but please understand that if you do, you do so on your own risk.

Yes, it would be useful indeed.

Those indeed are issues that should be overcome. We have not received any other reports of this yet, so in this instance and insofar your usecase is unique. As you point out yourself, it might have something to do with how the host is set up. Hosting is and most likely always will be one variable where it is very difficult to be able to cover everything. If you can send us more details though, we can try to accommodate for this specific scenario.


#16

Thank you very much for this detailed and useful answer. Anyway, I will have a restorable backup at hand before undertaking such an attempt.

It does not happen often that I have to set permissions when using FTP, but it happens. Until a few years ago, I was using the Article Manager CMS from InteractiveTools (v. 1), before switching to WP, and taking care of setting permissions properly for various folders was required - hence my question.

Regarding the issues encountered, I am really perplexed, since it is an hosting environment which allows for a variety of CMS, and even for the install of any selected version of WP or other CMS. They use Installatron. Also for updates, it allows the user to finetune them. Maybe this has something to do with Installatron, actually? This just comes to my mind as I am writing this.


#17

That seems to me to be the most likely explanation. Most of the people who have been installing ClassicPress so far via a one-click installer have been using cPanel.


#18

Thank you! In order to be sure and not to make a mistake, I have just sent a ticket to the support of SwissCenter - a reliable hosting environment. Let’s see what they advise to do.

By the way, our discussion also makes something else clear: a great boost for ClassicPress would be to have it added to the list of available CMS installations on Softaculous and Installatron, once the stable version 1 is out. I assume that it is already planned to approach them, or maybe it has already been done — but still I wanted to mention it, just in case.


#19

I don’t think there has been any specific discussion about Installatron – I, for one, had never heard of it before – but, yes, we have been discussing this idea.


#20

The problem is solved! Thanks to the very kind and efficient support of SwissCenter - a good opportunity to recommend them, by the way! (They went a long way to help me, even testing the switch to ClassicPress on one of their test sites in order to see if the issue could be reproduced: this is what I call real support!)

And it is not at all what we thought!

SwissCenter support noticed that I had installed the v. 0.5.0 of the plugin (I think that I had donwloaded it from GitHub). They installed the v. 0.4.0 of the plugin… and the switch took place instantly!

Thus it had nothing to do with Installatron or the hosting environment. I had thought it wise to install what I thought was the most recent version (0.5.0)… and I was wrong, 0.4.0 has to be used. Maybe this could help to solve other similar issues if they occur!

Anyway, thus I am glad to report that I have already two live sites migrated to CP, with two different hosting companies (a US one and a Swiss one), which will allow me to continue testing in different environments, and then move other sites to CP next year.

Thank you for your kind cooperation!