White screen of death when I'm trying to make a new post

I haven’t manage to get rid of the unknown bot that consumes the server’s bandwidth, but nobody has managed to hack my website either.
I have though another serious problem. I get white screen of death whenever I’m trying to publish a new post.
I got this problem last night after I tried to update a permalink on an existing post.
Whatever attempts I made after this to post something had the same result.
I removed a anti spam plugin in case this was causing the problem and I also used my backup in order to restore the database in case that this was the problem.
Pay attention now.
After the restore of the datbase I lost a blog post and I had to reupload it along with this images. This worked. The post was published normally.
When I tried to post the post that I was trying to edit yesterday I got for one more time the same white screen.
I thought that the problem was caused by some problem on the images of this post. So I got into the cpanel and I removed all the images, the old and the reuploaded new ones and I replaced them with other images that were edited and resized and renamed and without any metadata.

Same results. The white screen.
It seems that CP doesn’t want me to post this particular article.

Now my installation was updated at some unknown to me time and I know that because I got in the general settings screen the option that allows you to have a custom logo in the login screen.

I hadn’t post anything on my blog prior to this small update.
Is there any chance that the white screen is a result of the update and not of a corrupted database ( that I restored it after all from the backup) and not from the images ( that I replaced them after deleting the old and the older ones).

I don’t have any new plugin now running on my website other than those that I had previously and I can’t find any errors on the cpanel neither on the database and nor on the database server.

No errors anywhere but then I get the same white screen as soon as I click on the publish button.

It seems like it can’t save this particular post. This post has 1720 words. Is it perhaps a matter of the size of the post?

The white screen means there was an error in the code somewhere. There shouldn’t be a problem with the new upgrade, usually these errors are caused by a plugin.

As a next step can you look at the PHP error log for the server? If you have cPanel you can find it in there. If you’re not sure how to do this then you can ask your hosting company to help. It will make it easier for them if you can tell them a date and time you saw the white screen. You can also make it show the white screen again and then try not to do much with the site after that.

The only error that I found at the php.error.log is one that is from 10th of February 2020.
It is though from a plugin and I made some minor changes last night and this is a plugin for putting the images in categories but if the problem was caused by this plugin there should have been an entry on the logs.

The white screen appeared after I tried to change a permalink. It didn’t make the change and then it stopped publishing the posts though it saved them as empty drafts in the list of the posts.

I was able to publish only one post that existed already and I’ve lost it for a while,when I replaced the database with the one that I had from my backup, but I wasn’t able to publish any other post after that.

It seems like it is unable to save the content of new posts,

Are you sure that log file is the current one? With WordPress/ClassicPress, a white screen basically always means a PHP error.

It is the one that is in the logs directory in my website’s folder and is has the name php.error.log

Is there any other else somewhere else, to check it out?

There are of course other error.log files but only this one is php.error.log

The other files are /public_html/wp-includes/error_log


and some others that are definitely unrelated.

I just checked with the MySQL Databases thing in cpanel my database and it says that everything is ok.
I attemped also to publish something after I deactivated the Advance Editor and the Category plugin but I got for one more time the same white screen.

In the permalinks page I clicked to update my permalinks just in case it could fix the problem and I got something that I don’t know if it should be this way. This is a screenshot after I updated the settings of the permalings to a custom link with the post name.

Look which circle is marked. Is this normal?

And a final post before leaving you to go to sleep because I got tired.
It publishes posts that have only the title but I get the white screen when I add the article that I want to publish in the post.
I get the white screen no matter if I attempt to publish with or without images and with or without format and no matter if I post the content on the visual or the text editor.

Can someone explain to me please why although I have updated the permalinks with the Custom Structure and the postname, the dashboard shows that I have updated the permalinks with the sample post option?

PHP error logs can be in different places depending on your system. On Centos / cPanel systems, you might want to look in /home/<accountname>/logs. For comparision, public_html will be at /home/<accountname>/public_html. The file may be called error_log or perhaps marialenasarris.com.php.error_log. As i say, it varies from system to system and from hosting company to hosting company.

To me this does look like a PHP configuration issue, perhaps a lack of memory. If you’re using a cache plugin, I’d also clear the cache too. This is probably best done manually using FTP (or the cPanel file manager).

Re permalinks, sorry to have to ask such a basic question, but after selecting Custom Structure, did you click on the Save button afterwards? Post name should actually result in the same link as the custom structure anyway.

1 Like

The error.log file that I checked was the exact one you are talking about.
The marialenasarris_com.php.error.log that is in the logs directory.This has only one entry from the wp-media-category-management plugin from 20th of Feb 2020. No other errors.

I DID saved the permalinks setup and the screenshot was after saving the settings. I selected the custom strucure post name but after saving this setup ( that was the one that I had either way ) it looked the way it looks like at the screenshot.

I do use a cache plugin. I use the Wp Super Minify on my slightly modified css that is supposed to

Minify, cache and combine inline JavaScript and CSS files to improve page load time.

as it says.
But this plugin gets no updates because it is probably in a stable version and my custom theme doesn’t get updates either because I didn’t want to overwrite the changes.
The custom css is for the grid in the front page and the masonry that is included in the css and the lightbox that loads last on the website.

My custom css had always an error but that didn’t affect though anything on the website. The error warning was there in the CSS editor from the very beginning and everything was it its place and worked as it should. And I can’t see how the home page grid is connected with the posts’ permalinks which posts are loade on a completely different page. The home page where the css modifications apply is a different page from the blog page where the posts appear.

Anyway. I will deactivate the minify plugin to see if it is going to change anything.

I want to fix this thing and post the articles and move on. I have a trillion things to do and I’m stuck with this stupid matter now… :tired_face:

Thank you for the suggestions and your help. :slight_smile:

I removed the minify plugin and I installed another one to optimize the database, which it did though it didn’t find any errors and then I got rid of this plugin too and I tried to post something. I got the same result.

A white screen upon saving a new post. The post ends up in the list of posts as a draft but is not published and it doesn’t save and displays the content.
The new plugin that I installed didn’t find any old posts, or corrupted posts, errors or something else in the database or elsewhere. Everything is in its place but this thing doesn’t want to publish new posts.

Can you try it with a different browser and see what happens?

The same thing. :frowning:

Try temporarily disabling all plugins on the site?

If that works then you know that one of the site’s plugins is responsible for that error (or possibly a combination of 2 different plugins conflicting with each other).

If that doesn’t work then the next step would be to pass one of us the login details for the site via a private message so that we can take a look, if you are willing to do that.

Can I downgrade my CP installation. I mean to go from the version 1.2.0 to the previous one in order to exclude the posibility that this was caused from the recent release update?

1 Like

Have you tried using a standard default theme (twenty-something).

Ok I’ll disable all the plugins to see what happens.

Yes you can try that too. However I would suggest another, simpler step first - go to Dashboard > Updates and click “Re-install Now”.

Same thing with all plugins disabled. I renamed the plugins folder on the cpanel and tried to make a new post. Same thing. White screen and the post saved as an empty draft in the posts list.

I have already re installed the current release.

No because I never had this theme installed in the first place. The theme I had from the very beginning was the Pure and Simple one, that is currently used in its modified version. But the modifications are in the home page not on the posts page and if the problem was on the modifications of the home page then I would have the white screen on the home page too.

I get white screen only when I’m trying to publish a post.

Here is another thing that I have already done.
I changed the post page, the page that the posts are asigned to exclude the case that it was the page that has the posts corrupted and not the posts themselves.

Same result.