Could not communicate with the ClassicPress API server

Background:
I am trying to convert a Wordpress 4.9.23 site to ClassicPress using the “Switch to ClassicPress” plugin ver 1.4.1 .

Server running PHP version: 7.4.33. MySQL version: 10.3.39-MariaDB-cll-lve

I created a copy of my 5 year old live site to test how everything went first, I am working in that dev site.

Expected behavior

The website should switch to ClassicPress seamlessly with no hitches :slight_smile:

Current behavior

When I navigate to Tools/Switch to ClassicPress I see:

Could not communicate with the ClassicPress API server {“status”:“cURL error 60: SSL certificate problem: certificate has expired”}

Sorry, we can’t switch this site to ClassicPress at this time.

I was reminded of an old experience I had so I referred back to that discussion:

I searched and found this:

I added the “ClassicPress SSL Fix” as James suggested last time and the SSL plugin showed the same response as in the old problem, so, I “enabled insecure requests”.

But, there was no change back at the Switch to ClassicPress screen.

Context - My questions or comments

Does anyone have any idea what the hang up is?

Should I switch manually?

To switch manually, do I just over-write WP files? Just the WP-Admin Files?

RandyC

I just tested the migration plugin on WP 4.9.23 and not seeing any errors. The error suggests an SSL certificate may be expired, so something on your server might be expired or has an issue (could be OpenSSL bug depending on the version your server uses).

Does the migration plugin allow you to “show advanced controls”? I don’t remember off the top of my head if it does or not when this error is presented. If you can show advanced controls, you could try that.

But manual migration is an option. You want to make sure you keep wp-content, wp-config.php, and .htaccess safe (and any custom files/folders), and delete everything else. Then upload the files or unzip ClassicPress, making sure wp-content isn’t uploaded.

Make sure you have a backup, just in case.

Thank you Viktor for the help

Nope no advanced controls.

So in January 2022 Pross said:

Do we assume that is what my problem is?

But the “ClassicPress SSL Fix” isn’t working for me like it did for the other guy.

I have been with this host for over 5 years everything always works perfectly. Is this strange?

FWIW I also experienced that problem recently, albeit in a completely different context. I was unable to get the ClassicPress SSL Fix plugin to work even after enabling the 3-minute insecure requests, and I, similarly, had been with the host for 9 years. Because I left the host after the incident, I never got to the bottom of it, but it seems the host itself was behind the “SSL certificate problem: certificate has expired.” FWIW it was the only time I tried to use the migration plugin after my original migration to CP, and the only time I ever used the ClassicPress SSL Fix plugin.

Thank you Doug for letting me know that I am not the only one with this issue. Your story made me think about updates.

On the same server, I made a fresh install of CP 1.5.3 and FTPed a couple of outdated CP plugins.

After ClassicPress advised me that they were out of date, I updated to 1.6.0 and updated the plugins

Does the updater use some different method than the “Switch to CP” plugin?

I am not sure why I am still messing with this.

Were you able to get the migration plugin to work?

If an update worked, the migration plugin should work too. They rely on the same stuff to work.

That is what I was thinking when I made the test install on the same server.

But no, even though updates were discovered and installed, I just rechecked, and “switch to CP” still does not work without or with “ClassicPress SSL Fix” enabled.

I almost got motivated enough this last weekend to over-write the files like you explained, but I haven’t yet. I have been meaning to switch this site to CP for a couple years.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.